%global _empty_manifest_terminate_build 0
Name:		python-pysvn
Version:	0.1.0
Release:	1
Summary:	Svn for python.
License:	BSD License
URL:		https://github.com/leafvmaple/pysvn
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/e4/dc/0df56bfc41761bf2e33d72bace3bfaea38e70fe8a5f4c04b41e000c27a3a/pysvn-0.1.0.tar.gz
BuildArch:	noarch


%description
# pysvn

![PyPI](https://img.shields.io/pypi/v/pysvn)

This is a Python package that can operate `svn`, provide `log`, `diff`, `numstat` operation.

## Install

Binary installers for the latest released version are available at the `Pypi`.

```
python -m pip install --upgrade pysvn
```

## Usage

### Init

> initialize the client on `cwd`

```python
import pysvn

client = pysvn.Client(cwd = os.getcwd(), stdout = subprocess.PIPE)
```

### log

> Show the log messages for a set of revision(s) and/or path(s)..

```python
client.log(decoding = 'utf8')
```

### diff

> Display local changes or differences between two revisions or paths

```python
client.diff(start_version, end_version = None, decoding = 'utf8', cache = False)
```

### numstat

> Shows number of added and deleted lines in decimal notation and pathname

```python
client.numstat(start_version, end_version = None, decoding = 'utf8', cache = False)
```

## License

[BSD](https://github.com/leafvmaple/pysvn/blob/main/LICENSE)



%package -n python3-pysvn
Summary:	Svn for python.
Provides:	python-pysvn
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pysvn
# pysvn

![PyPI](https://img.shields.io/pypi/v/pysvn)

This is a Python package that can operate `svn`, provide `log`, `diff`, `numstat` operation.

## Install

Binary installers for the latest released version are available at the `Pypi`.

```
python -m pip install --upgrade pysvn
```

## Usage

### Init

> initialize the client on `cwd`

```python
import pysvn

client = pysvn.Client(cwd = os.getcwd(), stdout = subprocess.PIPE)
```

### log

> Show the log messages for a set of revision(s) and/or path(s)..

```python
client.log(decoding = 'utf8')
```

### diff

> Display local changes or differences between two revisions or paths

```python
client.diff(start_version, end_version = None, decoding = 'utf8', cache = False)
```

### numstat

> Shows number of added and deleted lines in decimal notation and pathname

```python
client.numstat(start_version, end_version = None, decoding = 'utf8', cache = False)
```

## License

[BSD](https://github.com/leafvmaple/pysvn/blob/main/LICENSE)



%package help
Summary:	Development documents and examples for pysvn
Provides:	python3-pysvn-doc
%description help
# pysvn

![PyPI](https://img.shields.io/pypi/v/pysvn)

This is a Python package that can operate `svn`, provide `log`, `diff`, `numstat` operation.

## Install

Binary installers for the latest released version are available at the `Pypi`.

```
python -m pip install --upgrade pysvn
```

## Usage

### Init

> initialize the client on `cwd`

```python
import pysvn

client = pysvn.Client(cwd = os.getcwd(), stdout = subprocess.PIPE)
```

### log

> Show the log messages for a set of revision(s) and/or path(s)..

```python
client.log(decoding = 'utf8')
```

### diff

> Display local changes or differences between two revisions or paths

```python
client.diff(start_version, end_version = None, decoding = 'utf8', cache = False)
```

### numstat

> Shows number of added and deleted lines in decimal notation and pathname

```python
client.numstat(start_version, end_version = None, decoding = 'utf8', cache = False)
```

## License

[BSD](https://github.com/leafvmaple/pysvn/blob/main/LICENSE)



%prep
%autosetup -n pysvn-0.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pysvn -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.0-1
- Package Spec generated