%global _empty_manifest_terminate_build 0
Name:		python-pytest-multihost
Version:	3.4
Release:	1
Summary:	Utility for writing multi-host tests for pytest
License:	GPL
URL:		https://pagure.io/python-pytest-multihost
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/99/bf/1f62e92ea6fc76814caf76d6713057c3dcadf9a42a955e28812d46691bf4/pytest-multihost-3.4.tar.gz
BuildArch:	noarch


%description
Release tarballs will be made available for download from Pagure Releases:
    https://pagure.io/releases/python-pytest-multihost/
The goal is to include this project in Fedora repositories. Until that happens,
you can use testing builds from COPR – see "Developer links" below.
You can also install using pip:
    https://pypi.python.org/pypi/pytest-multihost

%package -n python3-pytest-multihost
Summary:	Utility for writing multi-host tests for pytest
Provides:	python-pytest-multihost
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pytest-multihost
Release tarballs will be made available for download from Pagure Releases:
    https://pagure.io/releases/python-pytest-multihost/
The goal is to include this project in Fedora repositories. Until that happens,
you can use testing builds from COPR – see "Developer links" below.
You can also install using pip:
    https://pypi.python.org/pypi/pytest-multihost

%package help
Summary:	Development documents and examples for pytest-multihost
Provides:	python3-pytest-multihost-doc
%description help
Release tarballs will be made available for download from Pagure Releases:
    https://pagure.io/releases/python-pytest-multihost/
The goal is to include this project in Fedora repositories. Until that happens,
you can use testing builds from COPR – see "Developer links" below.
You can also install using pip:
    https://pypi.python.org/pypi/pytest-multihost

%prep
%autosetup -n pytest-multihost-3.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pytest-multihost -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 07 2023 Python_Bot <Python_Bot@openeuler.org> - 3.4-1
- Package Spec generated