%global _empty_manifest_terminate_build 0
Name:		python-Rtree
Version:	1.0.1
Release:	1
Summary:	R-Tree spatial index for Python GIS
License:	MIT
URL:		https://github.com/Toblerity/rtree
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/92/af/1d4066fd723c6304028a0296703f8a997f5dadd404645547233a21715311/Rtree-1.0.1.tar.gz

Requires:	python3-typing-extensions

%description
# Rtree: Spatial indexing for Python

![Build](https://github.com/Toblerity/rtree/workflows/Build/badge.svg)
[![PyPI version](https://badge.fury.io/py/Rtree.svg)](https://badge.fury.io/py/Rtree)


Rtree is a [ctypes](http://docs.python.org/library/ctypes.html) Python wrapper of [libspatialindex](https://libspatialindex.org/) that provides a
number of advanced spatial indexing features for the spatially curious Python
user.  These features include:

* Nearest neighbor search
* Intersection search
* Multi-dimensional indexes
* Clustered indexes (store Python pickles directly with index entries)
* Bulk loading
* Deletion
* Disk serialization
* Custom storage implementation (to implement spatial indexing in ZODB, for example)


Wheels are available for most major platforms, and `rtree` with bundled `libspatialindex` can be installed via pip:

```
pip install rtree
```

# Changes

## 1.0.1

* Fix up type hints #243 (thanks @oderby)
* Python 3.11 wheels #250 (thanks @ewouth)

## 1.0.0


* Python 3.7+ is now required (#212) (thanks @adamjstewart!)
* Type hints (#215 and others) (thanks @adamjstewart!)
* Python 3.10 wheels, including osx-arm64 #224
* Clean up libspatialindex C API mismatches #222 (thanks @musicinmybrain!)
* Many doc updates, fixes, and type hints (thanks @adamjstewart!) #212 #221 #217 #215
* __len__ method for index #194
* Prevent get_coordinate_pointers from mutating inputs #205 (thanks @sjones94549!)
* linux-aarch64 wheels #183 (thanks @odidev!)
* black (#218) and flake8 (#145) linting

https://github.com/Toblerity/rtree/releases/1.0.0


%package -n python3-Rtree
Summary:	R-Tree spatial index for Python GIS
Provides:	python-Rtree
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
BuildRequires:	python3-cffi
BuildRequires:	gcc
BuildRequires:	gdb
%description -n python3-Rtree
# Rtree: Spatial indexing for Python

![Build](https://github.com/Toblerity/rtree/workflows/Build/badge.svg)
[![PyPI version](https://badge.fury.io/py/Rtree.svg)](https://badge.fury.io/py/Rtree)


Rtree is a [ctypes](http://docs.python.org/library/ctypes.html) Python wrapper of [libspatialindex](https://libspatialindex.org/) that provides a
number of advanced spatial indexing features for the spatially curious Python
user.  These features include:

* Nearest neighbor search
* Intersection search
* Multi-dimensional indexes
* Clustered indexes (store Python pickles directly with index entries)
* Bulk loading
* Deletion
* Disk serialization
* Custom storage implementation (to implement spatial indexing in ZODB, for example)


Wheels are available for most major platforms, and `rtree` with bundled `libspatialindex` can be installed via pip:

```
pip install rtree
```

# Changes

## 1.0.1

* Fix up type hints #243 (thanks @oderby)
* Python 3.11 wheels #250 (thanks @ewouth)

## 1.0.0


* Python 3.7+ is now required (#212) (thanks @adamjstewart!)
* Type hints (#215 and others) (thanks @adamjstewart!)
* Python 3.10 wheels, including osx-arm64 #224
* Clean up libspatialindex C API mismatches #222 (thanks @musicinmybrain!)
* Many doc updates, fixes, and type hints (thanks @adamjstewart!) #212 #221 #217 #215
* __len__ method for index #194
* Prevent get_coordinate_pointers from mutating inputs #205 (thanks @sjones94549!)
* linux-aarch64 wheels #183 (thanks @odidev!)
* black (#218) and flake8 (#145) linting

https://github.com/Toblerity/rtree/releases/1.0.0


%package help
Summary:	Development documents and examples for Rtree
Provides:	python3-Rtree-doc
%description help
# Rtree: Spatial indexing for Python

![Build](https://github.com/Toblerity/rtree/workflows/Build/badge.svg)
[![PyPI version](https://badge.fury.io/py/Rtree.svg)](https://badge.fury.io/py/Rtree)


Rtree is a [ctypes](http://docs.python.org/library/ctypes.html) Python wrapper of [libspatialindex](https://libspatialindex.org/) that provides a
number of advanced spatial indexing features for the spatially curious Python
user.  These features include:

* Nearest neighbor search
* Intersection search
* Multi-dimensional indexes
* Clustered indexes (store Python pickles directly with index entries)
* Bulk loading
* Deletion
* Disk serialization
* Custom storage implementation (to implement spatial indexing in ZODB, for example)


Wheels are available for most major platforms, and `rtree` with bundled `libspatialindex` can be installed via pip:

```
pip install rtree
```

# Changes

## 1.0.1

* Fix up type hints #243 (thanks @oderby)
* Python 3.11 wheels #250 (thanks @ewouth)

## 1.0.0


* Python 3.7+ is now required (#212) (thanks @adamjstewart!)
* Type hints (#215 and others) (thanks @adamjstewart!)
* Python 3.10 wheels, including osx-arm64 #224
* Clean up libspatialindex C API mismatches #222 (thanks @musicinmybrain!)
* Many doc updates, fixes, and type hints (thanks @adamjstewart!) #212 #221 #217 #215
* __len__ method for index #194
* Prevent get_coordinate_pointers from mutating inputs #205 (thanks @sjones94549!)
* linux-aarch64 wheels #183 (thanks @odidev!)
* black (#218) and flake8 (#145) linting

https://github.com/Toblerity/rtree/releases/1.0.0


%prep
%autosetup -n Rtree-1.0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Rtree -f filelist.lst
%dir %{python3_sitearch}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.1-1
- Package Spec generated