%global _empty_manifest_terminate_build 0
Name:		python-sphinx-press-theme
Version:	0.8.0
Release:	1
Summary:	A Sphinx-doc theme based on Vuepress
License:	MIT
URL:		https://schettino72.github.io/sphinx_press_site/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/12/4b/73b14b65ba498e13c2c8eafac4d8ed9b750a916309116dae0a472dd23443/sphinx_press_theme-0.8.0.tar.gz
BuildArch:	noarch


%description
# sphinx_press_theme


[![PyPI](https://img.shields.io/pypi/v/sphinx_press_theme.svg)](https://pypi.python.org/pypi/sphinx_press_theme)

Please help me keep this project alive [![ko-fi](https://ko-fi.com/img/githubbutton_sm.svg)](https://ko-fi.com/A0A23ZL4A)


A modern responsive theme for python's [Sphinx](http://www.sphinx-doc.org) documentation generator.

See it in action on Press Theme own [website](https://schettino72.github.io/sphinx_press_site/)


This theme is based on [VuePress](https://vuepress.vuejs.org/).
It uses [Vue.js](https://vuejs.org/) & [Stylus](http://stylus-lang.com/) managed by
[vite](http://vitejs.dev/).



**Press** theme is still in **BETA**.
Contributions are welcome.

## Install

First install the theme:

```
$ pip install sphinx_press_theme
```

Sphinx version compatibility

|Sphinx |Press Theme|
|-------|-----------|
|4.X    | latest    |
|3.X    | 0.6.1     |
|2.X    | 0.5.1     |


## Usage

On Sphinx project's ``conf.py``: set the theme name to ``press``.

```
html_theme = "press"
```

See details on [configuration](https://schettino72.github.io/sphinx_press_site/configuration.html).


## Development

First build web assets:

```
cd ui
yarn build
```

Sphinx theme has a soft link to built assets...
Install theme locally with `pip install -e .`.

`docs` folder contains theme's own documentantion.

```
cd docs
make clean html
```

## Release

Set version on:

- `setup.py`
- `sphinx_press_theme/__init__.py`
- `sphinx_press_theme/theme.conf`
- `docs/source/conf.py`


## Website

To update website:

```
cd ../press_site
rsync -rvi ../sphinx_press_theme/docs/build/html/ .
git add --all
```

%package -n python3-sphinx-press-theme
Summary:	A Sphinx-doc theme based on Vuepress
Provides:	python-sphinx-press-theme
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sphinx-press-theme
# sphinx_press_theme


[![PyPI](https://img.shields.io/pypi/v/sphinx_press_theme.svg)](https://pypi.python.org/pypi/sphinx_press_theme)

Please help me keep this project alive [![ko-fi](https://ko-fi.com/img/githubbutton_sm.svg)](https://ko-fi.com/A0A23ZL4A)


A modern responsive theme for python's [Sphinx](http://www.sphinx-doc.org) documentation generator.

See it in action on Press Theme own [website](https://schettino72.github.io/sphinx_press_site/)


This theme is based on [VuePress](https://vuepress.vuejs.org/).
It uses [Vue.js](https://vuejs.org/) & [Stylus](http://stylus-lang.com/) managed by
[vite](http://vitejs.dev/).



**Press** theme is still in **BETA**.
Contributions are welcome.

## Install

First install the theme:

```
$ pip install sphinx_press_theme
```

Sphinx version compatibility

|Sphinx |Press Theme|
|-------|-----------|
|4.X    | latest    |
|3.X    | 0.6.1     |
|2.X    | 0.5.1     |


## Usage

On Sphinx project's ``conf.py``: set the theme name to ``press``.

```
html_theme = "press"
```

See details on [configuration](https://schettino72.github.io/sphinx_press_site/configuration.html).


## Development

First build web assets:

```
cd ui
yarn build
```

Sphinx theme has a soft link to built assets...
Install theme locally with `pip install -e .`.

`docs` folder contains theme's own documentantion.

```
cd docs
make clean html
```

## Release

Set version on:

- `setup.py`
- `sphinx_press_theme/__init__.py`
- `sphinx_press_theme/theme.conf`
- `docs/source/conf.py`


## Website

To update website:

```
cd ../press_site
rsync -rvi ../sphinx_press_theme/docs/build/html/ .
git add --all
```

%package help
Summary:	Development documents and examples for sphinx-press-theme
Provides:	python3-sphinx-press-theme-doc
%description help
# sphinx_press_theme


[![PyPI](https://img.shields.io/pypi/v/sphinx_press_theme.svg)](https://pypi.python.org/pypi/sphinx_press_theme)

Please help me keep this project alive [![ko-fi](https://ko-fi.com/img/githubbutton_sm.svg)](https://ko-fi.com/A0A23ZL4A)


A modern responsive theme for python's [Sphinx](http://www.sphinx-doc.org) documentation generator.

See it in action on Press Theme own [website](https://schettino72.github.io/sphinx_press_site/)


This theme is based on [VuePress](https://vuepress.vuejs.org/).
It uses [Vue.js](https://vuejs.org/) & [Stylus](http://stylus-lang.com/) managed by
[vite](http://vitejs.dev/).



**Press** theme is still in **BETA**.
Contributions are welcome.

## Install

First install the theme:

```
$ pip install sphinx_press_theme
```

Sphinx version compatibility

|Sphinx |Press Theme|
|-------|-----------|
|4.X    | latest    |
|3.X    | 0.6.1     |
|2.X    | 0.5.1     |


## Usage

On Sphinx project's ``conf.py``: set the theme name to ``press``.

```
html_theme = "press"
```

See details on [configuration](https://schettino72.github.io/sphinx_press_site/configuration.html).


## Development

First build web assets:

```
cd ui
yarn build
```

Sphinx theme has a soft link to built assets...
Install theme locally with `pip install -e .`.

`docs` folder contains theme's own documentantion.

```
cd docs
make clean html
```

## Release

Set version on:

- `setup.py`
- `sphinx_press_theme/__init__.py`
- `sphinx_press_theme/theme.conf`
- `docs/source/conf.py`


## Website

To update website:

```
cd ../press_site
rsync -rvi ../sphinx_press_theme/docs/build/html/ .
git add --all
```

%prep
%autosetup -n sphinx-press-theme-0.8.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sphinx-press-theme -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.0-1
- Package Spec generated