%global _empty_manifest_terminate_build 0
Name:		python-sqlalchemy-filters
Version:	0.12.0
Release:	1
Summary:	A library to filter SQLAlchemy queries.
License:	Apache License, Version 2.0
URL:		https://github.com/juliotrigo/sqlalchemy-filters
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/5d/3a/1bf3135bb7b46281f6ce815d25e43401a34612f939b42a993ac22cf16575/sqlalchemy-filters-0.12.0.tar.gz
BuildArch:	noarch

Requires:	python3-sqlalchemy
Requires:	python3-six
Requires:	python3-pytest
Requires:	python3-coverage
Requires:	python3-sqlalchemy-utils
Requires:	python3-flake8
Requires:	python3-restructuredtext-lint
Requires:	python3-Pygments
Requires:	python3-mysql-connector-python-rf
Requires:	python3-psycopg2
Requires:	python3-funcsigs

%description
    Filter, sort and paginate SQLAlchemy query objects. Ideal for
    exposing these actions over a REST API.

%package -n python3-sqlalchemy-filters
Summary:	A library to filter SQLAlchemy queries.
Provides:	python-sqlalchemy-filters
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sqlalchemy-filters
    Filter, sort and paginate SQLAlchemy query objects. Ideal for
    exposing these actions over a REST API.

%package help
Summary:	Development documents and examples for sqlalchemy-filters
Provides:	python3-sqlalchemy-filters-doc
%description help
    Filter, sort and paginate SQLAlchemy query objects. Ideal for
    exposing these actions over a REST API.

%prep
%autosetup -n sqlalchemy-filters-0.12.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sqlalchemy-filters -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.12.0-1
- Package Spec generated