%global _empty_manifest_terminate_build 0
Name:		python-vcstool
Version:	0.3.0
Release:	1
Summary:	vcstool provides a command line tool to invoke vcs commands on multiple repositories.
License:	Apache License, Version 2.0
URL:		https://github.com/dirk-thomas/vcstool
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/84/54/ae7f480b60aaaeb5e68b486136f1a557c352eebdd10603e7b5e9a903542f/vcstool-0.3.0.tar.gz
BuildArch:	noarch

Requires:	python3-PyYAML
Requires:	python3-setuptools

%description
vcstool enables batch commands on multiple different vcs repositories. Currently it supports git, hg, svn and bzr.




%package -n python3-vcstool
Summary:	vcstool provides a command line tool to invoke vcs commands on multiple repositories.
Provides:	python-vcstool
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-vcstool
vcstool enables batch commands on multiple different vcs repositories. Currently it supports git, hg, svn and bzr.




%package help
Summary:	Development documents and examples for vcstool
Provides:	python3-vcstool-doc
%description help
vcstool enables batch commands on multiple different vcs repositories. Currently it supports git, hg, svn and bzr.




%prep
%autosetup -n vcstool-0.3.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-vcstool -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0-1
- Package Spec generated