%global _empty_manifest_terminate_build 0
Name:		python-yattag
Version:	1.15.1
Release:	1
Summary:	Generate HTML or XML in a pythonic way. Pure python alternative to web template engines.Can fill HTML forms with default values and error messages.
License:	GNU Library or Lesser General Public License (LGPL)
URL:		https://www.yattag.org
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c6/21/93e572d8d799ff123592ff6d80f8c50cd08042e76657c6b3ec91ea3f7f7e/yattag-1.15.1.tar.gz
BuildArch:	noarch


%description
Nested html tags, no need to close tags.
    from yattag import Doc
    doc, tag, text = Doc().tagtext()
    with tag('html'):
        with tag('body', id = 'hello'):
            with tag('h1'):
                text('Hello world!')
    print(doc.getvalue())

%package -n python3-yattag
Summary:	Generate HTML or XML in a pythonic way. Pure python alternative to web template engines.Can fill HTML forms with default values and error messages.
Provides:	python-yattag
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-yattag
Nested html tags, no need to close tags.
    from yattag import Doc
    doc, tag, text = Doc().tagtext()
    with tag('html'):
        with tag('body', id = 'hello'):
            with tag('h1'):
                text('Hello world!')
    print(doc.getvalue())

%package help
Summary:	Development documents and examples for yattag
Provides:	python3-yattag-doc
%description help
Nested html tags, no need to close tags.
    from yattag import Doc
    doc, tag, text = Doc().tagtext()
    with tag('html'):
        with tag('body', id = 'hello'):
            with tag('h1'):
                text('Hello world!')
    print(doc.getvalue())

%prep
%autosetup -n yattag-1.15.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-yattag -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.15.1-1
- Package Spec generated