%global _empty_manifest_terminate_build 0
Name:		python-quart
Version:	0.18.4
Release:	1
Summary:	A Python ASGI web microframework with the same API as Flask
License:	MIT
URL:		https://github.com/pallets/quart/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c5/93/be1bd58558bd2f026b75a147c814f5117617dbb9f1e1144849ed2852d6c7/quart-0.18.4.tar.gz
BuildArch:	noarch

Requires:	python3-aiofiles
Requires:	python3-blinker
Requires:	python3-click
Requires:	python3-hypercorn
Requires:	python3-importlib_metadata
Requires:	python3-itsdangerous
Requires:	python3-jinja2
Requires:	python3-markupsafe
Requires:	python3-pydata_sphinx_theme
Requires:	python3-dotenv
Requires:	python3-typing_extensions
Requires:	python3-werkzeug

%description
|Build Status| |docs| |pypi| |python| |license| |chat|
Quart is an async Python web microframework. Using Quart you can,
* render and serve HTML templates,
* write (RESTful) JSON APIs,
* serve WebSockets,
* stream request and response data,
* do pretty much anything over the HTTP or WebSocket protocols.

%package -n python3-quart
Summary:	A Python ASGI web microframework with the same API as Flask
Provides:	python-quart
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-quart
|Build Status| |docs| |pypi| |python| |license| |chat|
Quart is an async Python web microframework. Using Quart you can,
* render and serve HTML templates,
* write (RESTful) JSON APIs,
* serve WebSockets,
* stream request and response data,
* do pretty much anything over the HTTP or WebSocket protocols.

%package help
Summary:	Development documents and examples for quart
Provides:	python3-quart-doc
%description help
|Build Status| |docs| |pypi| |python| |license| |chat|
Quart is an async Python web microframework. Using Quart you can,
* render and serve HTML templates,
* write (RESTful) JSON APIs,
* serve WebSockets,
* stream request and response data,
* do pretty much anything over the HTTP or WebSocket protocols.

%prep
%autosetup -n quart-0.18.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-quart -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.18.4-1
- Package Spec generated