%global _empty_manifest_terminate_build 0
Name:		python-docstring-parser
Version:	0.15
Release:	1
Summary:	Parse Python docstrings in reST, Google and Numpydoc format
License:	MIT
URL:		https://github.com/rr-/docstring_parser
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/e8/2d/ea1dfc15b909cc660f657a3a9d698a2916b7f3b05535a2d72e8d7ea3ad5b/docstring_parser-0.15.tar.gz
BuildArch:	noarch


%description
[![Build](https://github.com/rr-/docstring_parser/actions/workflows/build.yml/badge.svg)](https://github.com/rr-/docstring_parser/actions/workflows/build.yml)
Parse Python docstrings. Currently support ReST, Google, Numpydoc-style and
Epydoc docstrings.
Example usage:
```python
>>> from docstring_parser import parse
>>>
>>>
>>> docstring = parse(
>>>
>>> docstring.long_description
'Long description spanning multiple lines\n- First line\n- Second line\n- Third line'
>>> docstring.params[1].arg_name
'priority'
>>> docstring.raises[0].type_name
'ValueError'
```
Read [API Documentation](https://rr-.github.io/docstring_parser/).
# Contributing
To set up the project:
```sh
pip install --user poetry
git clone https://github.com/rr-/docstring_parser.git
cd docstring_parser
poetry install
poetry run pre-commit install
```
To run tests:
```
poetry run pytest
```

%package -n python3-docstring-parser
Summary:	Parse Python docstrings in reST, Google and Numpydoc format
Provides:	python-docstring-parser
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-docstring-parser
[![Build](https://github.com/rr-/docstring_parser/actions/workflows/build.yml/badge.svg)](https://github.com/rr-/docstring_parser/actions/workflows/build.yml)
Parse Python docstrings. Currently support ReST, Google, Numpydoc-style and
Epydoc docstrings.
Example usage:
```python
>>> from docstring_parser import parse
>>>
>>>
>>> docstring = parse(
>>>
>>> docstring.long_description
'Long description spanning multiple lines\n- First line\n- Second line\n- Third line'
>>> docstring.params[1].arg_name
'priority'
>>> docstring.raises[0].type_name
'ValueError'
```
Read [API Documentation](https://rr-.github.io/docstring_parser/).
# Contributing
To set up the project:
```sh
pip install --user poetry
git clone https://github.com/rr-/docstring_parser.git
cd docstring_parser
poetry install
poetry run pre-commit install
```
To run tests:
```
poetry run pytest
```

%package help
Summary:	Development documents and examples for docstring-parser
Provides:	python3-docstring-parser-doc
%description help
[![Build](https://github.com/rr-/docstring_parser/actions/workflows/build.yml/badge.svg)](https://github.com/rr-/docstring_parser/actions/workflows/build.yml)
Parse Python docstrings. Currently support ReST, Google, Numpydoc-style and
Epydoc docstrings.
Example usage:
```python
>>> from docstring_parser import parse
>>>
>>>
>>> docstring = parse(
>>>
>>> docstring.long_description
'Long description spanning multiple lines\n- First line\n- Second line\n- Third line'
>>> docstring.params[1].arg_name
'priority'
>>> docstring.raises[0].type_name
'ValueError'
```
Read [API Documentation](https://rr-.github.io/docstring_parser/).
# Contributing
To set up the project:
```sh
pip install --user poetry
git clone https://github.com/rr-/docstring_parser.git
cd docstring_parser
poetry install
poetry run pre-commit install
```
To run tests:
```
poetry run pytest
```

%prep
%autosetup -n docstring-parser-0.15

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-docstring-parser -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.15-1
- Package Spec generated