%global _empty_manifest_terminate_build 0
Name: python-apache-airflow-providers-databricks
Version: 4.0.1
Release: 1
Summary: Provider for Apache Airflow. Implements apache-airflow-providers-databricks package
License: Apache License 2.0
URL: https://airflow.apache.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bd/2c/85b8c72a122d899029d498324d2600714557e43b73da26e05d33e872c8e1/apache-airflow-providers-databricks-4.0.1.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-apache-airflow-providers-common-sql
Requires: python3-apache-airflow
Requires: python3-databricks-sql-connector
Requires: python3-requests
Requires: python3-apache-airflow-providers-common-sql
%description
This is a provider package for ``databricks`` provider. All classes for this provider package
are in ``airflow.providers.databricks`` python package.
You can find package information and changelog for the provider
in the `documentation `_.
%package -n python3-apache-airflow-providers-databricks
Summary: Provider for Apache Airflow. Implements apache-airflow-providers-databricks package
Provides: python-apache-airflow-providers-databricks
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-apache-airflow-providers-databricks
This is a provider package for ``databricks`` provider. All classes for this provider package
are in ``airflow.providers.databricks`` python package.
You can find package information and changelog for the provider
in the `documentation `_.
%package help
Summary: Development documents and examples for apache-airflow-providers-databricks
Provides: python3-apache-airflow-providers-databricks-doc
%description help
This is a provider package for ``databricks`` provider. All classes for this provider package
are in ``airflow.providers.databricks`` python package.
You can find package information and changelog for the provider
in the `documentation `_.
%prep
%autosetup -n apache-airflow-providers-databricks-4.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-apache-airflow-providers-databricks -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 4.0.1-1
- Package Spec generated