%global _empty_manifest_terminate_build 0
Name: python-s2sphere
Version: 0.2.5
Release: 1
Summary: Python implementation of the S2 Geometry Library
License: MIT
URL: http://s2sphere.readthedocs.io
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/01/8e/08260a5f03c642d3f6f040756425dc3f466842c4d5e978f6c2be960dde2f/s2sphere-0.2.5.tar.gz
BuildArch: noarch
%description
Python implementation of a part of the C++ `S2 geometry library `_.
Links: `Documentation `_,
`GitHub `_,
`Issue Tracker `_
Install with:
pip install s2sphere
Quick set up for development (see the `Developing section in the docs `_ for more details):
pip install .[tests]
nosetests -vv
%package -n python3-s2sphere
Summary: Python implementation of the S2 Geometry Library
Provides: python-s2sphere
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-s2sphere
Python implementation of a part of the C++ `S2 geometry library `_.
Links: `Documentation `_,
`GitHub `_,
`Issue Tracker `_
Install with:
pip install s2sphere
Quick set up for development (see the `Developing section in the docs `_ for more details):
pip install .[tests]
nosetests -vv
%package help
Summary: Development documents and examples for s2sphere
Provides: python3-s2sphere-doc
%description help
Python implementation of a part of the C++ `S2 geometry library `_.
Links: `Documentation `_,
`GitHub `_,
`Issue Tracker `_
Install with:
pip install s2sphere
Quick set up for development (see the `Developing section in the docs `_ for more details):
pip install .[tests]
nosetests -vv
%prep
%autosetup -n s2sphere-0.2.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-s2sphere -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 0.2.5-1
- Package Spec generated