%global _empty_manifest_terminate_build 0
Name:		python-pynput
Version:	1.7.6
Release:	1
Summary:	Monitor and control user input devices
License:	LGPLv3
URL:		https://github.com/moses-palmer/pynput
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d7/74/a231bca942b1cd9c4bb707788be325a61d26c7998bd25e88dc510d4b55c7/pynput-1.7.6.tar.gz
BuildArch:	noarch

Requires:	python3-six
Requires:	python3-evdev
Requires:	python3-xlib
Requires:	python3-enum34
Requires:	python3-pyobjc-framework-ApplicationServices
Requires:	python3-pyobjc-framework-Quartz

%description
This library allows you to control and monitor input devices.
Currently, mouse and keyboard input and monitoring are supported.
See `here <https://pynput.readthedocs.io/en/latest/>`_ for the full
documentation.

%package -n python3-pynput
Summary:	Monitor and control user input devices
Provides:	python-pynput
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pynput
This library allows you to control and monitor input devices.
Currently, mouse and keyboard input and monitoring are supported.
See `here <https://pynput.readthedocs.io/en/latest/>`_ for the full
documentation.

%package help
Summary:	Development documents and examples for pynput
Provides:	python3-pynput-doc
%description help
This library allows you to control and monitor input devices.
Currently, mouse and keyboard input and monitoring are supported.
See `here <https://pynput.readthedocs.io/en/latest/>`_ for the full
documentation.

%prep
%autosetup -n pynput-1.7.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pynput -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.7.6-1
- Package Spec generated