%global _empty_manifest_terminate_build 0
Name: python-apache-airflow-providers-google
Version: 8.12.0
Release: 1
Summary: Provider for Apache Airflow. Implements apache-airflow-providers-google package
License: Apache License 2.0
URL: https://airflow.apache.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/72/0a/444ec21f4f973b48c9dd86e784adda10c9e65f2e58194c71b5e28834505b/apache-airflow-providers-google-8.12.0.tar.gz
BuildArch: noarch
Requires: python3-PyOpenSSL
Requires: python3-PyYAML
Requires: python3-apache-airflow-providers-common-sql
Requires: python3-apache-airflow
Requires: python3-asgiref
Requires: python3-gcloud-aio-auth
Requires: python3-gcloud-aio-bigquery
Requires: python3-gcloud-aio-storage
Requires: python3-google-api-core
Requires: python3-google-api-python-client
Requires: python3-google-auth-httplib2
Requires: python3-google-auth-oauthlib
Requires: python3-google-auth
Requires: python3-google-cloud-aiplatform
Requires: python3-google-cloud-automl
Requires: python3-google-cloud-bigquery-datatransfer
Requires: python3-google-cloud-bigtable
Requires: python3-google-cloud-build
Requires: python3-google-cloud-compute
Requires: python3-google-cloud-container
Requires: python3-google-cloud-datacatalog
Requires: python3-google-cloud-dataflow-client
Requires: python3-google-cloud-dataform
Requires: python3-google-cloud-dataplex
Requires: python3-google-cloud-dataproc-metastore
Requires: python3-google-cloud-dataproc
Requires: python3-google-cloud-dlp
Requires: python3-google-cloud-kms
Requires: python3-google-cloud-language
Requires: python3-google-cloud-logging
Requires: python3-google-cloud-memcache
Requires: python3-google-cloud-monitoring
Requires: python3-google-cloud-orchestration-airflow
Requires: python3-google-cloud-os-login
Requires: python3-google-cloud-pubsub
Requires: python3-google-cloud-redis
Requires: python3-google-cloud-secret-manager
Requires: python3-google-cloud-spanner
Requires: python3-google-cloud-speech
Requires: python3-google-cloud-storage
Requires: python3-google-cloud-tasks
Requires: python3-google-cloud-texttospeech
Requires: python3-google-cloud-translate
Requires: python3-google-cloud-videointelligence
Requires: python3-google-cloud-vision
Requires: python3-google-cloud-workflows
Requires: python3-googleapis-common-protos
Requires: python3-grpcio-gcp
Requires: python3-grpcio-status
Requires: python3-grpcio
Requires: python3-httpx
Requires: python3-json-merge-patch
Requires: python3-looker-sdk
Requires: python3-pandas-gbq
Requires: python3-pandas
Requires: python3-proto-plus
Requires: python3-protobuf
Requires: python3-sqlalchemy-bigquery
Requires: python3-apache-airflow-providers-amazon
Requires: python3-apache-airflow-providers-apache-beam
Requires: python3-apache-beam[gcp]
Requires: python3-apache-airflow-providers-apache-cassandra
Requires: python3-apache-airflow-providers-cncf-kubernetes
Requires: python3-apache-airflow-providers-common-sql
Requires: python3-apache-airflow-providers-facebook
Requires: python3-plyvel
Requires: python3-apache-airflow-providers-microsoft-azure
Requires: python3-apache-airflow-providers-microsoft-mssql
Requires: python3-apache-airflow-providers-mysql
Requires: python3-apache-airflow-providers-oracle
Requires: python3-apache-airflow-providers-postgres
Requires: python3-apache-airflow-providers-presto
Requires: python3-apache-airflow-providers-salesforce
Requires: python3-apache-airflow-providers-sftp
Requires: python3-apache-airflow-providers-ssh
Requires: python3-apache-airflow-providers-trino
%description
This is a provider package for ``google`` provider. All classes for this provider package
are in ``airflow.providers.google`` python package.
You can find package information and changelog for the provider
in the `documentation `_.
%package -n python3-apache-airflow-providers-google
Summary: Provider for Apache Airflow. Implements apache-airflow-providers-google package
Provides: python-apache-airflow-providers-google
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-apache-airflow-providers-google
This is a provider package for ``google`` provider. All classes for this provider package
are in ``airflow.providers.google`` python package.
You can find package information and changelog for the provider
in the `documentation `_.
%package help
Summary: Development documents and examples for apache-airflow-providers-google
Provides: python3-apache-airflow-providers-google-doc
%description help
This is a provider package for ``google`` provider. All classes for this provider package
are in ``airflow.providers.google`` python package.
You can find package information and changelog for the provider
in the `documentation `_.
%prep
%autosetup -n apache-airflow-providers-google-8.12.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-apache-airflow-providers-google -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 8.12.0-1
- Package Spec generated