%global _empty_manifest_terminate_build 0
Name: python-betacal
Version: 1.1.0
Release: 1
Summary: Beta calibration
License: MIT
URL: https://betacal.github.io/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f6/76/edaa7f9688a8a1458063ec2495ef552d99a9186b01bbbd752e61391d8f8d/betacal-1.1.0.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scikit-learn
%description
# Beta calibration - Python package
This package provides a BetaCalibration class which allows the user to fit any of our three proposed beta calibration models. For the paper and tutorials, check [https://betacal.github.io/](https://betacal.github.io/).
## Dependencies
* [Numpy] - NumPy is the fundamental package for scientific computing with
Python.
* [Scikit-learn] - Machine Learning in Python.
## Usage
- Install from pip using "pip install betacal"
- Alternatively, download from the repository, cd to the folder and use "pip install ."
- Once installed, import the package using "import betacal"
## Unittest
Create a virtual environment with the necessary dependencies
```
virtualenv venv
. ./venv/bin/activate
pip install -r requirements.txt
```
and then run the script runtests.sh
```
bash runtests.sh
```
## License
MIT
[//]: # (References)
[Numpy]:
[Scikit-learn]:
%package -n python3-betacal
Summary: Beta calibration
Provides: python-betacal
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-betacal
# Beta calibration - Python package
This package provides a BetaCalibration class which allows the user to fit any of our three proposed beta calibration models. For the paper and tutorials, check [https://betacal.github.io/](https://betacal.github.io/).
## Dependencies
* [Numpy] - NumPy is the fundamental package for scientific computing with
Python.
* [Scikit-learn] - Machine Learning in Python.
## Usage
- Install from pip using "pip install betacal"
- Alternatively, download from the repository, cd to the folder and use "pip install ."
- Once installed, import the package using "import betacal"
## Unittest
Create a virtual environment with the necessary dependencies
```
virtualenv venv
. ./venv/bin/activate
pip install -r requirements.txt
```
and then run the script runtests.sh
```
bash runtests.sh
```
## License
MIT
[//]: # (References)
[Numpy]:
[Scikit-learn]:
%package help
Summary: Development documents and examples for betacal
Provides: python3-betacal-doc
%description help
# Beta calibration - Python package
This package provides a BetaCalibration class which allows the user to fit any of our three proposed beta calibration models. For the paper and tutorials, check [https://betacal.github.io/](https://betacal.github.io/).
## Dependencies
* [Numpy] - NumPy is the fundamental package for scientific computing with
Python.
* [Scikit-learn] - Machine Learning in Python.
## Usage
- Install from pip using "pip install betacal"
- Alternatively, download from the repository, cd to the folder and use "pip install ."
- Once installed, import the package using "import betacal"
## Unittest
Create a virtual environment with the necessary dependencies
```
virtualenv venv
. ./venv/bin/activate
pip install -r requirements.txt
```
and then run the script runtests.sh
```
bash runtests.sh
```
## License
MIT
[//]: # (References)
[Numpy]:
[Scikit-learn]:
%prep
%autosetup -n betacal-1.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-betacal -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 1.1.0-1
- Package Spec generated