%global _empty_manifest_terminate_build 0
Name: python-jsonargparse
Version: 4.20.1
Release: 1
Summary: Implement minimal boilerplate CLIs derived from type hints and parse from command line, config files and environment variables.
License: MIT
URL: https://github.com/omni-us/jsonargparse
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3c/ba/2fc1147c68c07711aff021c77e305d2b03c4a67f8c1775fc58d77306475f/jsonargparse-4.20.1.tar.gz
BuildArch: noarch
Requires: python3-PyYAML
Requires: python3-contextvars
Requires: python3-dataclasses
Requires: python3-docstring-parser
Requires: python3-typeshed-client
Requires: python3-jsonschema
Requires: python3-requests
Requires: python3-fsspec
Requires: python3-argcomplete
Requires: python3-ruyaml
Requires: python3-omegaconf
Requires: python3-reconplogger
Requires: python3-jsonnet-binary
Requires: python3-jsonnet
Requires: python3-typing-extensions
Requires: python3-argcomplete
Requires: python3-coverage
Requires: python3-types-PyYAML
Requires: python3-responses
Requires: python3-types-requests
Requires: python3-Sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-autodocsumm
Requires: python3-sphinx-autodoc-typehints
Requires: python3-pylint
Requires: python3-mypy
Requires: python3-pre-commit
Requires: python3-tox
Requires: python3-pycodestyle
Requires: python3-Sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-autodocsumm
Requires: python3-sphinx-autodoc-typehints
Requires: python3-fsspec
Requires: python3-jsonnet-binary
Requires: python3-jsonnet
Requires: python3-jsonschema
Requires: python3-bump2version
Requires: python3-types-PyYAML
Requires: python3-mypy
Requires: python3-omegaconf
Requires: python3-pylint
Requires: python3-reconplogger
Requires: python3-ruyaml
Requires: python3-docstring-parser
Requires: python3-typeshed-client
Requires: python3-coverage
Requires: python3-types-PyYAML
Requires: python3-responses
Requires: python3-types-requests
Requires: python3-coverage
Requires: python3-types-PyYAML
Requires: python3-typing-extensions
Requires: python3-requests
%description
https://github.com/omni-us/jsonargparse/
This package is an extension to python's argparse which simplifies parsing of
configuration options from command line arguments, json configuration files
(`yaml `__ or `jsonnet `__ supersets),
environment variables and hard-coded defaults.
The aim is similar to other projects such as `configargparse
`__, `yconf
`__, `confuse
`__, `typer
`__, `OmegaConf
`__, `Fire
`__ and `click
`__. The obvious question is, why yet another
package similar to many already existing ones? The answer is simply that none of
the existing projects had the exact features we wanted and after analyzing the
alternatives it seemed simpler to start a new project.
%package -n python3-jsonargparse
Summary: Implement minimal boilerplate CLIs derived from type hints and parse from command line, config files and environment variables.
Provides: python-jsonargparse
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-jsonargparse
https://github.com/omni-us/jsonargparse/
This package is an extension to python's argparse which simplifies parsing of
configuration options from command line arguments, json configuration files
(`yaml `__ or `jsonnet `__ supersets),
environment variables and hard-coded defaults.
The aim is similar to other projects such as `configargparse
`__, `yconf
`__, `confuse
`__, `typer
`__, `OmegaConf
`__, `Fire
`__ and `click
`__. The obvious question is, why yet another
package similar to many already existing ones? The answer is simply that none of
the existing projects had the exact features we wanted and after analyzing the
alternatives it seemed simpler to start a new project.
%package help
Summary: Development documents and examples for jsonargparse
Provides: python3-jsonargparse-doc
%description help
https://github.com/omni-us/jsonargparse/
This package is an extension to python's argparse which simplifies parsing of
configuration options from command line arguments, json configuration files
(`yaml `__ or `jsonnet `__ supersets),
environment variables and hard-coded defaults.
The aim is similar to other projects such as `configargparse
`__, `yconf
`__, `confuse
`__, `typer
`__, `OmegaConf
`__, `Fire
`__ and `click
`__. The obvious question is, why yet another
package similar to many already existing ones? The answer is simply that none of
the existing projects had the exact features we wanted and after analyzing the
alternatives it seemed simpler to start a new project.
%prep
%autosetup -n jsonargparse-4.20.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-jsonargparse -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 4.20.1-1
- Package Spec generated