%global _empty_manifest_terminate_build 0
Name: python-lambda-decorators
Version: 0.6.0
Release: 1
Summary: A collection of useful decorators for making AWS Lambda handlers
License: MIT
URL: http://lambda-decorators.readthedocs.io
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8d/0e/dfad34fbd523758cdaa31130644df87bd1e9ea64d8bafd950d6c6461312c/lambda-decorators-0.6.0.tar.gz
BuildArch: noarch
%description
|Version|_ |Docs|_ |Build|_ |SayThanks|_
A collection of useful decorators for making AWS Lambda handlers
``lambda_decorators`` is a collection of useful decorators for writing Python
handlers for `AWS Lambda `_. They allow you to
avoid boiler plate for common things such as CORS headers, JSON serialization,
etc.
%package -n python3-lambda-decorators
Summary: A collection of useful decorators for making AWS Lambda handlers
Provides: python-lambda-decorators
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-lambda-decorators
|Version|_ |Docs|_ |Build|_ |SayThanks|_
A collection of useful decorators for making AWS Lambda handlers
``lambda_decorators`` is a collection of useful decorators for writing Python
handlers for `AWS Lambda `_. They allow you to
avoid boiler plate for common things such as CORS headers, JSON serialization,
etc.
%package help
Summary: Development documents and examples for lambda-decorators
Provides: python3-lambda-decorators-doc
%description help
|Version|_ |Docs|_ |Build|_ |SayThanks|_
A collection of useful decorators for making AWS Lambda handlers
``lambda_decorators`` is a collection of useful decorators for writing Python
handlers for `AWS Lambda `_. They allow you to
avoid boiler plate for common things such as CORS headers, JSON serialization,
etc.
%prep
%autosetup -n lambda-decorators-0.6.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-lambda-decorators -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 0.6.0-1
- Package Spec generated