%global _empty_manifest_terminate_build 0
Name: python-pyngrok
Version: 5.2.1
Release: 1
Summary: A Python wrapper for ngrok.
License: MIT
URL: https://github.com/alexdlaird/pyngrok
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bd/36/169c177c3124a69abaee285b1572e5ed9d27088fa4c5fa104d1da8f17326/pyngrok-5.2.1.tar.gz
BuildArch: noarch
%description

[](https://badge.fury.io/py/pyngrok)
[](https://github.com/alexdlaird/pyngrok/actions?query=workflow%3ACI%2FCD)
[](https://codecov.io/gh/alexdlaird/pyngrok)
[](https://pyngrok.readthedocs.io/en/latest/?badge=latest)
[](https://pypi.org/project/pyngrok/)
[](https://pypi.org/project/pyngrok/)
[](https://twitter.com/intent/tweet?text=Check+out+%23pyngrok%2C+a+Python+wrapper+for+%23ngrok+that+lets+you+programmatically+open+secure+%23tunnels+to+local+web+servers%2C+build+%23webhook+integrations%2C+enable+SSH+access%2C+test+chatbots%2C+demo+from+your+own+machine%2C+and+more.%0D%0A%0D%0A&url=https://github.com/alexdlaird/pyngrok&via=alexdlaird)
`pyngrok` is a Python wrapper for `ngrok` that manages its own binary, making `ngrok` available via a convenient Python
API.
[ngrok](https://ngrok.com) is a reverse proxy tool that opens secure tunnels from public URLs to localhost, perfect
for exposing local web servers, building webhook integrations, enabling SSH access, testing chatbots, demoing from
your own machine, and more, and its made even more powerful with native Python integration through `pyngrok`.
## Installation
`pyngrok` is available on [PyPI](https://pypi.org/project/pyngrok/) and can be installed
using `pip`:
```sh
pip install pyngrok
```
or `conda`:
```sh
conda install -c conda-forge pyngrok
```
That's it! `pyngrok` is now available as a package to our Python projects, and `ngrok` is now available from
the command line.
## Basic Usage
To open a tunnel, use the [`connect`](https://pyngrok.readthedocs.io/en/latest/api.html#pyngrok.ngrok.connect) method,
which returns a `NgrokTunnel`, and this returned object has a reference to the public URL generated by `ngrok` in its
`public_url` attribute.
```python
from pyngrok import ngrok
# Open a HTTP tunnel on the default port 80
# .ngrok.io" -> "http://localhost:80">
http_tunnel = ngrok.connect()
# Open a SSH tunnel
# "localhost:22">
ssh_tunnel = ngrok.connect(22, "tcp")
```
The [`connect`](https://pyngrok.readthedocs.io/en/latest/api.html#pyngrok.ngrok.connect) method takes `kwargs` as
well, which allows us to pass additional properties that are [supported by ngrok](https://ngrok.com/docs#tunnel-definitions).
This package puts the default `ngrok` binary on our path, so all features of `ngrok` are
available on the command line.
```sh
ngrok http 80
```
For details on how to fully leverage `ngrok` from the command line, see [ngrok's official documentation](https://ngrok.com/docs).
## Documentation
For more advanced usage, `pyngrok`'s official documentation is available at [http://pyngrok.readthedocs.io](http://pyngrok.readthedocs.io).
### `ngrok` Version Compatibility
`pyngrok` is compatible with `ngrok` v2 and v3, but by default it will install v2. To install v3 instead,
set `ngrok_version` in [`PyngrokConfig`](https://pyngrok.readthedocs.io/en/latest/api.html#pyngrok.conf.PyngrokConfig):
```python
from pyngrok import conf
conf.get_default().ngrok_version = "v3"
```
### Python 2.7
The last version of `pyngrok` that supports Python 2.7 is 4.1.x, so we need to pin `pyngrok>=4.1,<4.2` if we still want
to use `pyngrok` with this version of Python. Its legacy documentation can be found [here](https://pyngrok.readthedocs.io/en/4.1.x/).
## Contributing
If you would like to get involved, be sure to review the [Contribution Guide](https://github.com/alexdlaird/pyngrok/blob/main/CONTRIBUTING.rst).
Want to contribute financially? If you've found `pyngrok` useful, [a donation](https://www.paypal.me/alexdlaird) would
also be greatly appreciated!
%package -n python3-pyngrok
Summary: A Python wrapper for ngrok.
Provides: python-pyngrok
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyngrok

[](https://badge.fury.io/py/pyngrok)
[](https://github.com/alexdlaird/pyngrok/actions?query=workflow%3ACI%2FCD)
[](https://codecov.io/gh/alexdlaird/pyngrok)
[](https://pyngrok.readthedocs.io/en/latest/?badge=latest)
[](https://pypi.org/project/pyngrok/)
[](https://pypi.org/project/pyngrok/)
[](https://twitter.com/intent/tweet?text=Check+out+%23pyngrok%2C+a+Python+wrapper+for+%23ngrok+that+lets+you+programmatically+open+secure+%23tunnels+to+local+web+servers%2C+build+%23webhook+integrations%2C+enable+SSH+access%2C+test+chatbots%2C+demo+from+your+own+machine%2C+and+more.%0D%0A%0D%0A&url=https://github.com/alexdlaird/pyngrok&via=alexdlaird)
`pyngrok` is a Python wrapper for `ngrok` that manages its own binary, making `ngrok` available via a convenient Python
API.
[ngrok](https://ngrok.com) is a reverse proxy tool that opens secure tunnels from public URLs to localhost, perfect
for exposing local web servers, building webhook integrations, enabling SSH access, testing chatbots, demoing from
your own machine, and more, and its made even more powerful with native Python integration through `pyngrok`.
## Installation
`pyngrok` is available on [PyPI](https://pypi.org/project/pyngrok/) and can be installed
using `pip`:
```sh
pip install pyngrok
```
or `conda`:
```sh
conda install -c conda-forge pyngrok
```
That's it! `pyngrok` is now available as a package to our Python projects, and `ngrok` is now available from
the command line.
## Basic Usage
To open a tunnel, use the [`connect`](https://pyngrok.readthedocs.io/en/latest/api.html#pyngrok.ngrok.connect) method,
which returns a `NgrokTunnel`, and this returned object has a reference to the public URL generated by `ngrok` in its
`public_url` attribute.
```python
from pyngrok import ngrok
# Open a HTTP tunnel on the default port 80
# .ngrok.io" -> "http://localhost:80">
http_tunnel = ngrok.connect()
# Open a SSH tunnel
# "localhost:22">
ssh_tunnel = ngrok.connect(22, "tcp")
```
The [`connect`](https://pyngrok.readthedocs.io/en/latest/api.html#pyngrok.ngrok.connect) method takes `kwargs` as
well, which allows us to pass additional properties that are [supported by ngrok](https://ngrok.com/docs#tunnel-definitions).
This package puts the default `ngrok` binary on our path, so all features of `ngrok` are
available on the command line.
```sh
ngrok http 80
```
For details on how to fully leverage `ngrok` from the command line, see [ngrok's official documentation](https://ngrok.com/docs).
## Documentation
For more advanced usage, `pyngrok`'s official documentation is available at [http://pyngrok.readthedocs.io](http://pyngrok.readthedocs.io).
### `ngrok` Version Compatibility
`pyngrok` is compatible with `ngrok` v2 and v3, but by default it will install v2. To install v3 instead,
set `ngrok_version` in [`PyngrokConfig`](https://pyngrok.readthedocs.io/en/latest/api.html#pyngrok.conf.PyngrokConfig):
```python
from pyngrok import conf
conf.get_default().ngrok_version = "v3"
```
### Python 2.7
The last version of `pyngrok` that supports Python 2.7 is 4.1.x, so we need to pin `pyngrok>=4.1,<4.2` if we still want
to use `pyngrok` with this version of Python. Its legacy documentation can be found [here](https://pyngrok.readthedocs.io/en/4.1.x/).
## Contributing
If you would like to get involved, be sure to review the [Contribution Guide](https://github.com/alexdlaird/pyngrok/blob/main/CONTRIBUTING.rst).
Want to contribute financially? If you've found `pyngrok` useful, [a donation](https://www.paypal.me/alexdlaird) would
also be greatly appreciated!
%package help
Summary: Development documents and examples for pyngrok
Provides: python3-pyngrok-doc
%description help

[](https://badge.fury.io/py/pyngrok)
[](https://github.com/alexdlaird/pyngrok/actions?query=workflow%3ACI%2FCD)
[](https://codecov.io/gh/alexdlaird/pyngrok)
[](https://pyngrok.readthedocs.io/en/latest/?badge=latest)
[](https://pypi.org/project/pyngrok/)
[](https://pypi.org/project/pyngrok/)
[](https://twitter.com/intent/tweet?text=Check+out+%23pyngrok%2C+a+Python+wrapper+for+%23ngrok+that+lets+you+programmatically+open+secure+%23tunnels+to+local+web+servers%2C+build+%23webhook+integrations%2C+enable+SSH+access%2C+test+chatbots%2C+demo+from+your+own+machine%2C+and+more.%0D%0A%0D%0A&url=https://github.com/alexdlaird/pyngrok&via=alexdlaird)
`pyngrok` is a Python wrapper for `ngrok` that manages its own binary, making `ngrok` available via a convenient Python
API.
[ngrok](https://ngrok.com) is a reverse proxy tool that opens secure tunnels from public URLs to localhost, perfect
for exposing local web servers, building webhook integrations, enabling SSH access, testing chatbots, demoing from
your own machine, and more, and its made even more powerful with native Python integration through `pyngrok`.
## Installation
`pyngrok` is available on [PyPI](https://pypi.org/project/pyngrok/) and can be installed
using `pip`:
```sh
pip install pyngrok
```
or `conda`:
```sh
conda install -c conda-forge pyngrok
```
That's it! `pyngrok` is now available as a package to our Python projects, and `ngrok` is now available from
the command line.
## Basic Usage
To open a tunnel, use the [`connect`](https://pyngrok.readthedocs.io/en/latest/api.html#pyngrok.ngrok.connect) method,
which returns a `NgrokTunnel`, and this returned object has a reference to the public URL generated by `ngrok` in its
`public_url` attribute.
```python
from pyngrok import ngrok
# Open a HTTP tunnel on the default port 80
# .ngrok.io" -> "http://localhost:80">
http_tunnel = ngrok.connect()
# Open a SSH tunnel
# "localhost:22">
ssh_tunnel = ngrok.connect(22, "tcp")
```
The [`connect`](https://pyngrok.readthedocs.io/en/latest/api.html#pyngrok.ngrok.connect) method takes `kwargs` as
well, which allows us to pass additional properties that are [supported by ngrok](https://ngrok.com/docs#tunnel-definitions).
This package puts the default `ngrok` binary on our path, so all features of `ngrok` are
available on the command line.
```sh
ngrok http 80
```
For details on how to fully leverage `ngrok` from the command line, see [ngrok's official documentation](https://ngrok.com/docs).
## Documentation
For more advanced usage, `pyngrok`'s official documentation is available at [http://pyngrok.readthedocs.io](http://pyngrok.readthedocs.io).
### `ngrok` Version Compatibility
`pyngrok` is compatible with `ngrok` v2 and v3, but by default it will install v2. To install v3 instead,
set `ngrok_version` in [`PyngrokConfig`](https://pyngrok.readthedocs.io/en/latest/api.html#pyngrok.conf.PyngrokConfig):
```python
from pyngrok import conf
conf.get_default().ngrok_version = "v3"
```
### Python 2.7
The last version of `pyngrok` that supports Python 2.7 is 4.1.x, so we need to pin `pyngrok>=4.1,<4.2` if we still want
to use `pyngrok` with this version of Python. Its legacy documentation can be found [here](https://pyngrok.readthedocs.io/en/4.1.x/).
## Contributing
If you would like to get involved, be sure to review the [Contribution Guide](https://github.com/alexdlaird/pyngrok/blob/main/CONTRIBUTING.rst).
Want to contribute financially? If you've found `pyngrok` useful, [a donation](https://www.paypal.me/alexdlaird) would
also be greatly appreciated!
%prep
%autosetup -n pyngrok-5.2.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyngrok -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 5.2.1-1
- Package Spec generated