%global _empty_manifest_terminate_build 0
Name:		python-sounddevice
Version:	0.4.6
Release:	1
Summary:	Play and Record Sound with Python
License:	MIT
URL:		http://python-sounddevice.readthedocs.io/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d8/3b/c989bde59a1eb333eb2a692f508a09408df562a3f99047a2d030e160cb11/sounddevice-0.4.6.tar.gz

Requires:	python3-CFFI
Requires:	python3-NumPy

%description
This Python_ module provides bindings for the PortAudio_ library and a few
convenience functions to play and record NumPy_ arrays containing audio signals.
The ``sounddevice`` module is available for Linux, macOS and Windows.
Documentation:
   https://python-sounddevice.readthedocs.io/
Source code repository and issue tracker:
   https://github.com/spatialaudio/python-sounddevice/
License:
   MIT -- see the file ``LICENSE`` for details.

%package -n python3-sounddevice
Summary:	Play and Record Sound with Python
Provides:	python-sounddevice
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
BuildRequires:	python3-cffi
BuildRequires:	gcc
BuildRequires:	gdb
%description -n python3-sounddevice
This Python_ module provides bindings for the PortAudio_ library and a few
convenience functions to play and record NumPy_ arrays containing audio signals.
The ``sounddevice`` module is available for Linux, macOS and Windows.
Documentation:
   https://python-sounddevice.readthedocs.io/
Source code repository and issue tracker:
   https://github.com/spatialaudio/python-sounddevice/
License:
   MIT -- see the file ``LICENSE`` for details.

%package help
Summary:	Development documents and examples for sounddevice
Provides:	python3-sounddevice-doc
%description help
This Python_ module provides bindings for the PortAudio_ library and a few
convenience functions to play and record NumPy_ arrays containing audio signals.
The ``sounddevice`` module is available for Linux, macOS and Windows.
Documentation:
   https://python-sounddevice.readthedocs.io/
Source code repository and issue tracker:
   https://github.com/spatialaudio/python-sounddevice/
License:
   MIT -- see the file ``LICENSE`` for details.

%prep
%autosetup -n sounddevice-0.4.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sounddevice -f filelist.lst
%dir %{python3_sitearch}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.6-1
- Package Spec generated