%global _empty_manifest_terminate_build 0
Name: python-spacy-alignments
Version: 0.9.0
Release: 1
Summary: A spaCy package for the Rust tokenizations library
License: MIT
URL: https://github.com/explosion/spacy-alignments
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2f/04/bf4dd61e7afbd247a5391ba6dd5353d02367b3282e6fb3d9c7c935809984/spacy-alignments-0.9.0.tar.gz
%description
# spacy-alignments: Align tokenizations for spaCy + transformers
A spaCy package for Yohei Tamura's Rust
[tokenizations](https://github.com/tamuhey/tokenizations/) library with Python
bindings.
## Installation
```
pip install -U pip setuptools wheel
pip install spacy-alignments
```
If no binary wheel is available for your platform, you will need to [install
Rust](https://www.rust-lang.org/tools/install) in order to build
`spacy-alignments` from source.
## spacy-alignments vs. pytokenizations
The `spacy_alignments` module is a drop-in replacement for `tokenizations`:
```python
import spacy_alignments as tokenizations
a2b, b2a = tokenizations.get_alignments(["å", "BC"], ["abc"])
assert a2b == [[0], [0]]
assert b2a == [[0, 1]]
```
The only difference between this package and the original
[`pytokenizations`](https://pypi.org/project/pytokenizations/) is that it
switches the build system to `setuptools-rust` to make it easier for us at
Explosion to build source and binary packages for a wider range of platforms.
%package -n python3-spacy-alignments
Summary: A spaCy package for the Rust tokenizations library
Provides: python-spacy-alignments
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-spacy-alignments
# spacy-alignments: Align tokenizations for spaCy + transformers
A spaCy package for Yohei Tamura's Rust
[tokenizations](https://github.com/tamuhey/tokenizations/) library with Python
bindings.
## Installation
```
pip install -U pip setuptools wheel
pip install spacy-alignments
```
If no binary wheel is available for your platform, you will need to [install
Rust](https://www.rust-lang.org/tools/install) in order to build
`spacy-alignments` from source.
## spacy-alignments vs. pytokenizations
The `spacy_alignments` module is a drop-in replacement for `tokenizations`:
```python
import spacy_alignments as tokenizations
a2b, b2a = tokenizations.get_alignments(["å", "BC"], ["abc"])
assert a2b == [[0], [0]]
assert b2a == [[0, 1]]
```
The only difference between this package and the original
[`pytokenizations`](https://pypi.org/project/pytokenizations/) is that it
switches the build system to `setuptools-rust` to make it easier for us at
Explosion to build source and binary packages for a wider range of platforms.
%package help
Summary: Development documents and examples for spacy-alignments
Provides: python3-spacy-alignments-doc
%description help
# spacy-alignments: Align tokenizations for spaCy + transformers
A spaCy package for Yohei Tamura's Rust
[tokenizations](https://github.com/tamuhey/tokenizations/) library with Python
bindings.
## Installation
```
pip install -U pip setuptools wheel
pip install spacy-alignments
```
If no binary wheel is available for your platform, you will need to [install
Rust](https://www.rust-lang.org/tools/install) in order to build
`spacy-alignments` from source.
## spacy-alignments vs. pytokenizations
The `spacy_alignments` module is a drop-in replacement for `tokenizations`:
```python
import spacy_alignments as tokenizations
a2b, b2a = tokenizations.get_alignments(["å", "BC"], ["abc"])
assert a2b == [[0], [0]]
assert b2a == [[0, 1]]
```
The only difference between this package and the original
[`pytokenizations`](https://pypi.org/project/pytokenizations/) is that it
switches the build system to `setuptools-rust` to make it easier for us at
Explosion to build source and binary packages for a wider range of platforms.
%prep
%autosetup -n spacy-alignments-0.9.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-spacy-alignments -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 0.9.0-1
- Package Spec generated