%global _empty_manifest_terminate_build 0
Name: python-stix2-patterns
Version: 2.0.0
Release: 1
Summary: Validate STIX 2 Patterns.
License: BSD License
URL: https://github.com/oasis-open/cti-pattern-validator
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/55/38/13c114116f6b9028b91fe4dac486446abc2ecdaffd55deda70489ba88519/stix2-patterns-2.0.0.tar.gz
BuildArch: noarch
Requires: python3-antlr4-python3-runtime
Requires: python3-six
Requires: python3-sphinx
Requires: python3-sphinx-prompt
Requires: python3-coverage
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-bumpversion
Requires: python3-check-manifest
Requires: python3-pre-commit
Requires: python3-sphinx-prompt
Requires: python3-tox
Requires: python3-sphinx
Requires: python3-coverage
Requires: python3-pytest
Requires: python3-pytest-cov
%description
This is an `OASIS TC Open Repository
`__. See the
`Governance <#governance>`__ section for more information.
The STIX 2 Pattern Validator is a software tool for checking the syntax of the
Cyber Threat Intelligence (CTI) STIX Pattern expressions, which are used within
STIX to express conditions (prepresented with the Cyber Observable data model)
that indicate particular cyber threat activity. The repository contains source
code, an ANTLR grammar, automated tests and associated documentation for the
tool. The validator can be used as a command-line tool or as a Python library
which can be included in other applications.
|Build_Status| |Coverage| |Version|
%package -n python3-stix2-patterns
Summary: Validate STIX 2 Patterns.
Provides: python-stix2-patterns
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-stix2-patterns
This is an `OASIS TC Open Repository
`__. See the
`Governance <#governance>`__ section for more information.
The STIX 2 Pattern Validator is a software tool for checking the syntax of the
Cyber Threat Intelligence (CTI) STIX Pattern expressions, which are used within
STIX to express conditions (prepresented with the Cyber Observable data model)
that indicate particular cyber threat activity. The repository contains source
code, an ANTLR grammar, automated tests and associated documentation for the
tool. The validator can be used as a command-line tool or as a Python library
which can be included in other applications.
|Build_Status| |Coverage| |Version|
%package help
Summary: Development documents and examples for stix2-patterns
Provides: python3-stix2-patterns-doc
%description help
This is an `OASIS TC Open Repository
`__. See the
`Governance <#governance>`__ section for more information.
The STIX 2 Pattern Validator is a software tool for checking the syntax of the
Cyber Threat Intelligence (CTI) STIX Pattern expressions, which are used within
STIX to express conditions (prepresented with the Cyber Observable data model)
that indicate particular cyber threat activity. The repository contains source
code, an ANTLR grammar, automated tests and associated documentation for the
tool. The validator can be used as a command-line tool or as a Python library
which can be included in other applications.
|Build_Status| |Coverage| |Version|
%prep
%autosetup -n stix2-patterns-2.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-stix2-patterns -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 2.0.0-1
- Package Spec generated