%global _empty_manifest_terminate_build 0
Name: python-django-render-block
Version: 0.9.2
Release: 1
Summary: Render a particular block from a template to a string.
License: ISC License (ISCL)
URL: https://github.com/clokep/django-render-block
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/02/04/c26ca6307aa12e8fa695dee9ac6f9020aa32435fbb6ff9d6168123f7c1a4/django-render-block-0.9.2.tar.gz
BuildArch: noarch
Requires: python3-django
Requires: python3-Jinja2
%description
* Render a specific block from a template
* Fully supports the Django templating engine
* Partially supports the `Jinja2 `__ engine: it does
not currently process the ``extends`` tag.
%package -n python3-django-render-block
Summary: Render a particular block from a template to a string.
Provides: python-django-render-block
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-render-block
* Render a specific block from a template
* Fully supports the Django templating engine
* Partially supports the `Jinja2 `__ engine: it does
not currently process the ``extends`` tag.
%package help
Summary: Development documents and examples for django-render-block
Provides: python3-django-render-block-doc
%description help
* Render a specific block from a template
* Fully supports the Django templating engine
* Partially supports the `Jinja2 `__ engine: it does
not currently process the ``extends`` tag.
%prep
%autosetup -n django-render-block-0.9.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-render-block -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.9.2-1
- Package Spec generated