%global _empty_manifest_terminate_build 0
Name: python-face-recognition
Version: 1.3.0
Release: 1
Summary: Recognize faces from Python or from the command line
License: MIT license
URL: https://github.com/ageitgey/face_recognition
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6c/49/75dda409b94841f01cbbc34114c9b67ec618265084e4d12d37ab838f4fd3/face_recognition-1.3.0.tar.gz
BuildArch: noarch
Requires: python3-face-recognition-models
Requires: python3-Click
Requires: python3-dlib
Requires: python3-numpy
Requires: python3-Pillow
%description
| Recognize and manipulate faces from Python or from the command line
with
| the world's simplest face recognition library.
| Built using `dlib `__'s state-of-the-art face
recognition
| built with deep learning. The model has an accuracy of 99.38% on the
| `Labeled Faces in the Wild `__
benchmark.
| This also provides a simple ``face_recognition`` command line tool
that lets
| you do face recognition on a folder of images from the command line!
| |PyPI|
| |Build Status|
| |Documentation Status|
%package -n python3-face-recognition
Summary: Recognize faces from Python or from the command line
Provides: python-face-recognition
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-face-recognition
| Recognize and manipulate faces from Python or from the command line
with
| the world's simplest face recognition library.
| Built using `dlib `__'s state-of-the-art face
recognition
| built with deep learning. The model has an accuracy of 99.38% on the
| `Labeled Faces in the Wild `__
benchmark.
| This also provides a simple ``face_recognition`` command line tool
that lets
| you do face recognition on a folder of images from the command line!
| |PyPI|
| |Build Status|
| |Documentation Status|
%package help
Summary: Development documents and examples for face-recognition
Provides: python3-face-recognition-doc
%description help
| Recognize and manipulate faces from Python or from the command line
with
| the world's simplest face recognition library.
| Built using `dlib `__'s state-of-the-art face
recognition
| built with deep learning. The model has an accuracy of 99.38% on the
| `Labeled Faces in the Wild `__
benchmark.
| This also provides a simple ``face_recognition`` command line tool
that lets
| you do face recognition on a folder of images from the command line!
| |PyPI|
| |Build Status|
| |Documentation Status|
%prep
%autosetup -n face-recognition-1.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-face-recognition -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 1.3.0-1
- Package Spec generated