%global _empty_manifest_terminate_build 0
Name:		python-bzt
Version:	1.16.22
Release:	1
Summary:	Taurus Tool for Continuous Testing
License:	Apache 2.0
URL:		http://gettaurus.org/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/8c/74/6454459d35b2e4a868ee173102f14e584c77a07b0a7078fb301e125204bc/bzt-1.16.22.tar.gz
BuildArch:	noarch

Requires:	python3-astunparse
Requires:	python3-colorlog
Requires:	python3-cssselect
Requires:	python3-fuzzyset2
Requires:	python3-hdrpy
Requires:	python3-influxdb
Requires:	python3-lxml
Requires:	python3-molotov
Requires:	python3-progressbar33
Requires:	python3-psutil
Requires:	python3-socketio
Requires:	python3-pyyaml
Requires:	python3-requests
Requires:	python3-terminaltables
Requires:	python3-urwid
Requires:	python3-websocket-client
Requires:	python3-Cython
Requires:	python3-pyvirtualdisplay
Requires:	python3-colorama

%description
execution:
- concurrency: 10
  ramp-up: 1m
  hold-for: 1m30s
  scenario: simple
scenarios:
  simple:
    think-time: 0.75
    requests:
    - http://blazedemo.com/
    - http://blazedemo.com/vacation.html
```
Then run `bzt test.yml`. After the tool finishes, observe resulting summary stats in console log (more reporting options [here](http://gettaurus.org/docs/Reporting.md)). All artifact files from the run will be placed in the directory mentioned in console log. Read more on command-line tool usage [here](http://gettaurus.org/docs/CommandLine.md).
![Analytics](https://ga-beacon.appspot.com/UA-63369152-1/taurus/readme)

%package -n python3-bzt
Summary:	Taurus Tool for Continuous Testing
Provides:	python-bzt
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-bzt
execution:
- concurrency: 10
  ramp-up: 1m
  hold-for: 1m30s
  scenario: simple
scenarios:
  simple:
    think-time: 0.75
    requests:
    - http://blazedemo.com/
    - http://blazedemo.com/vacation.html
```
Then run `bzt test.yml`. After the tool finishes, observe resulting summary stats in console log (more reporting options [here](http://gettaurus.org/docs/Reporting.md)). All artifact files from the run will be placed in the directory mentioned in console log. Read more on command-line tool usage [here](http://gettaurus.org/docs/CommandLine.md).
![Analytics](https://ga-beacon.appspot.com/UA-63369152-1/taurus/readme)

%package help
Summary:	Development documents and examples for bzt
Provides:	python3-bzt-doc
%description help
execution:
- concurrency: 10
  ramp-up: 1m
  hold-for: 1m30s
  scenario: simple
scenarios:
  simple:
    think-time: 0.75
    requests:
    - http://blazedemo.com/
    - http://blazedemo.com/vacation.html
```
Then run `bzt test.yml`. After the tool finishes, observe resulting summary stats in console log (more reporting options [here](http://gettaurus.org/docs/Reporting.md)). All artifact files from the run will be placed in the directory mentioned in console log. Read more on command-line tool usage [here](http://gettaurus.org/docs/CommandLine.md).
![Analytics](https://ga-beacon.appspot.com/UA-63369152-1/taurus/readme)

%prep
%autosetup -n bzt-1.16.22

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-bzt -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.16.22-1
- Package Spec generated