%global _empty_manifest_terminate_build 0
Name:		python-zabbix-api
Version:	0.5.5
Release:	1
Summary:	Zabbix API
License:	GNU LGPL 2.1
URL:		https://github.com/gescheit/scripts
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/53/ff/b0817b791bce12fb7def0aefafd09f4336f952e21c7b202a1f579f25146c/zabbix-api-0.5.5.tar.gz
BuildArch:	noarch


%description
This is an implementation of the Zabbix API in Python.
Please note that the Zabbix API is still in a draft state,
and subject to change.

Implementations of the Zabbix API in other languages may
be found on the wiki.

Zabbix 1.8, 2.0, 2.2, 2.4, 3.0 and 3.2 are supported.
Python 2 and 3 are supported.

Future versions must be supported too, if there is no deep changes.

Installation:
```sh
# pip install zabbix-api
```

Short example:

```python
>>> from zabbix_api import ZabbixAPI
>>> zapi = ZabbixAPI(server="https://server/")
>>> zapi.login("login", "password")
>>> zapi.trigger.get({"expandExpression": "extend", "triggerids": range(0, 100)})
```

See also:
* http://www.zabbix.com/wiki/doc/api
* https://www.zabbix.com/documentation/2.4/manual/api
* http://www.zabbix.com/forum/showthread.php?t=15218


%package -n python3-zabbix-api
Summary:	Zabbix API
Provides:	python-zabbix-api
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-zabbix-api
This is an implementation of the Zabbix API in Python.
Please note that the Zabbix API is still in a draft state,
and subject to change.

Implementations of the Zabbix API in other languages may
be found on the wiki.

Zabbix 1.8, 2.0, 2.2, 2.4, 3.0 and 3.2 are supported.
Python 2 and 3 are supported.

Future versions must be supported too, if there is no deep changes.

Installation:
```sh
# pip install zabbix-api
```

Short example:

```python
>>> from zabbix_api import ZabbixAPI
>>> zapi = ZabbixAPI(server="https://server/")
>>> zapi.login("login", "password")
>>> zapi.trigger.get({"expandExpression": "extend", "triggerids": range(0, 100)})
```

See also:
* http://www.zabbix.com/wiki/doc/api
* https://www.zabbix.com/documentation/2.4/manual/api
* http://www.zabbix.com/forum/showthread.php?t=15218


%package help
Summary:	Development documents and examples for zabbix-api
Provides:	python3-zabbix-api-doc
%description help
This is an implementation of the Zabbix API in Python.
Please note that the Zabbix API is still in a draft state,
and subject to change.

Implementations of the Zabbix API in other languages may
be found on the wiki.

Zabbix 1.8, 2.0, 2.2, 2.4, 3.0 and 3.2 are supported.
Python 2 and 3 are supported.

Future versions must be supported too, if there is no deep changes.

Installation:
```sh
# pip install zabbix-api
```

Short example:

```python
>>> from zabbix_api import ZabbixAPI
>>> zapi = ZabbixAPI(server="https://server/")
>>> zapi.login("login", "password")
>>> zapi.trigger.get({"expandExpression": "extend", "triggerids": range(0, 100)})
```

See also:
* http://www.zabbix.com/wiki/doc/api
* https://www.zabbix.com/documentation/2.4/manual/api
* http://www.zabbix.com/forum/showthread.php?t=15218


%prep
%autosetup -n zabbix-api-0.5.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-zabbix-api -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.5-1
- Package Spec generated