%global _empty_manifest_terminate_build 0
Name: python-namegenerator
Version: 1.0.6
Release: 1
Summary: Generate Random Names for anything
License: MIT License
URL: https://yoginth.gitlab.io
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1b/2b/dd6d5b718c8fcefd30b9844a6c2386983c78ea37fa6094aea67d2e694719/namegenerator-1.0.6.tar.gz
BuildArch: noarch
%description
## Name Generator
> Generate Random Names for anything
## Screenshot
## Inspired by
- [Noxan's Gist](https://gist.github.com/noxan/5845351)
- [Names Module by Trey Hunner](https://pypi.org/project/names/)
## Install
```
$ pip install namegenerator
```
## Usage
```py
import namegenerator
print (namegenerator.gen())
#=> scaly-peach-centipede
```
## Get Help
There are few ways to get help:
1. Please [post questions on Stack Overflow](https://stackoverflow.com/questions/ask). You can open issues with questions, as long you add a link to your Stack Overflow question.
2. For bug reports and feature requests, open issues.
3. For direct and quick help, you can [email me](mailto://yoginth@zoho.com).
## How to contribute
Have an idea? Found a bug? See [how to contribute][contributing].
Thanks!
## License
[MIT][license]
[LICENSE]: https://yoginth.mit-license.org/
[contributing]: /CONTRIBUTING.md
%package -n python3-namegenerator
Summary: Generate Random Names for anything
Provides: python-namegenerator
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-namegenerator
## Name Generator
> Generate Random Names for anything
## Screenshot
## Inspired by
- [Noxan's Gist](https://gist.github.com/noxan/5845351)
- [Names Module by Trey Hunner](https://pypi.org/project/names/)
## Install
```
$ pip install namegenerator
```
## Usage
```py
import namegenerator
print (namegenerator.gen())
#=> scaly-peach-centipede
```
## Get Help
There are few ways to get help:
1. Please [post questions on Stack Overflow](https://stackoverflow.com/questions/ask). You can open issues with questions, as long you add a link to your Stack Overflow question.
2. For bug reports and feature requests, open issues.
3. For direct and quick help, you can [email me](mailto://yoginth@zoho.com).
## How to contribute
Have an idea? Found a bug? See [how to contribute][contributing].
Thanks!
## License
[MIT][license]
[LICENSE]: https://yoginth.mit-license.org/
[contributing]: /CONTRIBUTING.md
%package help
Summary: Development documents and examples for namegenerator
Provides: python3-namegenerator-doc
%description help
## Name Generator
> Generate Random Names for anything
## Screenshot
## Inspired by
- [Noxan's Gist](https://gist.github.com/noxan/5845351)
- [Names Module by Trey Hunner](https://pypi.org/project/names/)
## Install
```
$ pip install namegenerator
```
## Usage
```py
import namegenerator
print (namegenerator.gen())
#=> scaly-peach-centipede
```
## Get Help
There are few ways to get help:
1. Please [post questions on Stack Overflow](https://stackoverflow.com/questions/ask). You can open issues with questions, as long you add a link to your Stack Overflow question.
2. For bug reports and feature requests, open issues.
3. For direct and quick help, you can [email me](mailto://yoginth@zoho.com).
## How to contribute
Have an idea? Found a bug? See [how to contribute][contributing].
Thanks!
## License
[MIT][license]
[LICENSE]: https://yoginth.mit-license.org/
[contributing]: /CONTRIBUTING.md
%prep
%autosetup -n namegenerator-1.0.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-namegenerator -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 1.0.6-1
- Package Spec generated