%global _empty_manifest_terminate_build 0
Name: python-aegea
Version: 4.3.4
Release: 1
Summary: Amazon Web Services Operator Interface
License: Apache Software License
URL: https://github.com/kislyuk/aegea
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e2/7d/ebf0a37606394f0103ef81287501cc6794760fe4f130227056bbc45afc41/aegea-4.3.4.tar.gz
BuildArch: noarch
Requires: python3-boto3
Requires: python3-argcomplete
Requires: python3-paramiko
Requires: python3-requests
Requires: python3-tweak
Requires: python3-pyyaml
Requires: python3-dateutil
Requires: python3-babel
Requires: python3-ipwhois
Requires: python3-uritemplate
Requires: python3-chalice
Requires: python3-coverage
Requires: python3-wheel
Requires: python3-ruff
Requires: python3-mypy
Requires: python3-types-python-dateutil
Requires: python3-types-requests
Requires: python3-types-PyYAML
%description
*Aegea* is a command line interface (CLI) that provides a set of essential commands and terminal dashboards for
operators of Amazon Web Services (AWS) accounts. Aegea lets you build AMIs and Docker images using the
`cloud-init `_ config management package, manage config roles, launch and monitor
instances and services, and manage AWS resources including ELB, RDS, and AWS Batch. Aegea is designed to be used in
conjunction with the existing functionality of the `AWS CLI `_ and
`boto3 `_.
Installation
~~~~~~~~~~~~
pip install aegea
Run ``aws configure`` to configure `IAM `_ access credentials that will be used by the
``aws`` and ``aegea`` commands. You can create a new IAM key at https://console.aws.amazon.com/iam/home#/users. See the
`AWS CLI documentation `_ for more details.
Aegea commands
~~~~~~~~~~~~~~
Below are some highlights from Aegea's suite of commands. Run ``aegea --help`` to see the full list of commands.
+----------------------------+-----------------------------------------------------------------------------------------+
| Command | Key functionality |
+============================+=========================================================================================+
| `aegea ls` | List running EC2 instances |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea launch` | Launch EC2 instances and specify options such as spot tenancy, AMI, instance type, etc. |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea ssh`, `aegea scp` | Connect to running instances, transfer files using AWS Systems Manager or other options |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea batch` | Submit, manage and monitor AWS Batch jobs |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea ecs` | Monitor ECS clusters and run Fargate tasks |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea build-ami` | Build EC2 AMIs using cloud-init configuration scripts |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea build-docker-image` | Build AWS ECR docker images using Dockerfiles or cloud-init scripts |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea logs` | Download AWS CloudWatch Logs contents using S3 export |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea grep` | Query AWS CloudWatch Logs contents using CloudWatch Logs Insights |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea cost` | List AWS cost reports generated by AWS Cost Explorer |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea secrets` | List and manage secrets stored in AWS Secrets Manager |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea cloudtrail` | Query AWS CloudTrail events to audit the security of your AWS account |
+----------------------------+-----------------------------------------------------------------------------------------+
%package -n python3-aegea
Summary: Amazon Web Services Operator Interface
Provides: python-aegea
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-aegea
*Aegea* is a command line interface (CLI) that provides a set of essential commands and terminal dashboards for
operators of Amazon Web Services (AWS) accounts. Aegea lets you build AMIs and Docker images using the
`cloud-init `_ config management package, manage config roles, launch and monitor
instances and services, and manage AWS resources including ELB, RDS, and AWS Batch. Aegea is designed to be used in
conjunction with the existing functionality of the `AWS CLI `_ and
`boto3 `_.
Installation
~~~~~~~~~~~~
pip install aegea
Run ``aws configure`` to configure `IAM `_ access credentials that will be used by the
``aws`` and ``aegea`` commands. You can create a new IAM key at https://console.aws.amazon.com/iam/home#/users. See the
`AWS CLI documentation `_ for more details.
Aegea commands
~~~~~~~~~~~~~~
Below are some highlights from Aegea's suite of commands. Run ``aegea --help`` to see the full list of commands.
+----------------------------+-----------------------------------------------------------------------------------------+
| Command | Key functionality |
+============================+=========================================================================================+
| `aegea ls` | List running EC2 instances |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea launch` | Launch EC2 instances and specify options such as spot tenancy, AMI, instance type, etc. |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea ssh`, `aegea scp` | Connect to running instances, transfer files using AWS Systems Manager or other options |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea batch` | Submit, manage and monitor AWS Batch jobs |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea ecs` | Monitor ECS clusters and run Fargate tasks |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea build-ami` | Build EC2 AMIs using cloud-init configuration scripts |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea build-docker-image` | Build AWS ECR docker images using Dockerfiles or cloud-init scripts |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea logs` | Download AWS CloudWatch Logs contents using S3 export |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea grep` | Query AWS CloudWatch Logs contents using CloudWatch Logs Insights |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea cost` | List AWS cost reports generated by AWS Cost Explorer |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea secrets` | List and manage secrets stored in AWS Secrets Manager |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea cloudtrail` | Query AWS CloudTrail events to audit the security of your AWS account |
+----------------------------+-----------------------------------------------------------------------------------------+
%package help
Summary: Development documents and examples for aegea
Provides: python3-aegea-doc
%description help
*Aegea* is a command line interface (CLI) that provides a set of essential commands and terminal dashboards for
operators of Amazon Web Services (AWS) accounts. Aegea lets you build AMIs and Docker images using the
`cloud-init `_ config management package, manage config roles, launch and monitor
instances and services, and manage AWS resources including ELB, RDS, and AWS Batch. Aegea is designed to be used in
conjunction with the existing functionality of the `AWS CLI `_ and
`boto3 `_.
Installation
~~~~~~~~~~~~
pip install aegea
Run ``aws configure`` to configure `IAM `_ access credentials that will be used by the
``aws`` and ``aegea`` commands. You can create a new IAM key at https://console.aws.amazon.com/iam/home#/users. See the
`AWS CLI documentation `_ for more details.
Aegea commands
~~~~~~~~~~~~~~
Below are some highlights from Aegea's suite of commands. Run ``aegea --help`` to see the full list of commands.
+----------------------------+-----------------------------------------------------------------------------------------+
| Command | Key functionality |
+============================+=========================================================================================+
| `aegea ls` | List running EC2 instances |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea launch` | Launch EC2 instances and specify options such as spot tenancy, AMI, instance type, etc. |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea ssh`, `aegea scp` | Connect to running instances, transfer files using AWS Systems Manager or other options |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea batch` | Submit, manage and monitor AWS Batch jobs |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea ecs` | Monitor ECS clusters and run Fargate tasks |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea build-ami` | Build EC2 AMIs using cloud-init configuration scripts |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea build-docker-image` | Build AWS ECR docker images using Dockerfiles or cloud-init scripts |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea logs` | Download AWS CloudWatch Logs contents using S3 export |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea grep` | Query AWS CloudWatch Logs contents using CloudWatch Logs Insights |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea cost` | List AWS cost reports generated by AWS Cost Explorer |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea secrets` | List and manage secrets stored in AWS Secrets Manager |
+----------------------------+-----------------------------------------------------------------------------------------+
| `aegea cloudtrail` | Query AWS CloudTrail events to audit the security of your AWS account |
+----------------------------+-----------------------------------------------------------------------------------------+
%prep
%autosetup -n aegea-4.3.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-aegea -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 4.3.4-1
- Package Spec generated