%global _empty_manifest_terminate_build 0
Name: python-characteristic
Version: 14.3.0
Release: 1
Summary: Python attributes without boilerplate.
License: MIT
URL: https://characteristic.readthedocs.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/dc/66/54b7a4758ea44fbc93895c7745060005272560fb2c356f2a6f7448ef9a80/characteristic-14.3.0.tar.gz
BuildArch: noarch
%description
``characteristic`` is an `MIT `_-licensed Python package with class decorators that ease the chores of implementing the most common attribute-related object protocols.
You just specify the attributes to work with and ``characteristic`` gives you any or all of:
- a nice human-readable ``__repr__``,
- a complete set of comparison methods,
- immutability for attributes,
- and a kwargs-based initializer (that cooperates with your existing one and optionally even checks the types of the arguments)
*without* writing dull boilerplate code again and again.
This gives you the power to use actual classes with actual types in your code instead of confusing ``tuple``\ s or confusingly behaving ``namedtuple``\ s.
So put down that type-less data structures and welcome some class into your life!
``characteristic``\ ’s documentation lives at `Read the Docs `_, the code on `GitHub `_.
It’s rigorously tested on Python 2.6, 2.7, 3.3+, and PyPy.
%package -n python3-characteristic
Summary: Python attributes without boilerplate.
Provides: python-characteristic
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-characteristic
``characteristic`` is an `MIT `_-licensed Python package with class decorators that ease the chores of implementing the most common attribute-related object protocols.
You just specify the attributes to work with and ``characteristic`` gives you any or all of:
- a nice human-readable ``__repr__``,
- a complete set of comparison methods,
- immutability for attributes,
- and a kwargs-based initializer (that cooperates with your existing one and optionally even checks the types of the arguments)
*without* writing dull boilerplate code again and again.
This gives you the power to use actual classes with actual types in your code instead of confusing ``tuple``\ s or confusingly behaving ``namedtuple``\ s.
So put down that type-less data structures and welcome some class into your life!
``characteristic``\ ’s documentation lives at `Read the Docs `_, the code on `GitHub `_.
It’s rigorously tested on Python 2.6, 2.7, 3.3+, and PyPy.
%package help
Summary: Development documents and examples for characteristic
Provides: python3-characteristic-doc
%description help
``characteristic`` is an `MIT `_-licensed Python package with class decorators that ease the chores of implementing the most common attribute-related object protocols.
You just specify the attributes to work with and ``characteristic`` gives you any or all of:
- a nice human-readable ``__repr__``,
- a complete set of comparison methods,
- immutability for attributes,
- and a kwargs-based initializer (that cooperates with your existing one and optionally even checks the types of the arguments)
*without* writing dull boilerplate code again and again.
This gives you the power to use actual classes with actual types in your code instead of confusing ``tuple``\ s or confusingly behaving ``namedtuple``\ s.
So put down that type-less data structures and welcome some class into your life!
``characteristic``\ ’s documentation lives at `Read the Docs `_, the code on `GitHub `_.
It’s rigorously tested on Python 2.6, 2.7, 3.3+, and PyPy.
%prep
%autosetup -n characteristic-14.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-characteristic -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 14.3.0-1
- Package Spec generated