%global _empty_manifest_terminate_build 0
Name: python-django-pgtrigger
Version: 4.6.0
Release: 1
Summary: Postgres trigger support integrated with Django models.
License: BSD-3-Clause
URL: https://github.com/Opus10/django-pgtrigger
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/69/da/c62fefb70592c43d3a1d46301f34f2d3d3a1b881fbd7fcf335b6d40bc24f/django-pgtrigger-4.6.0.tar.gz
BuildArch: noarch
Requires: python3-django
Requires: python3-importlib_metadata
%description
Triggers can solve a variety of complex problems more reliably, performantly, and succinctly than application code.
For example,
* Protecting operations on rows or columns (``pgtrigger.Protect``).
* Making read-only models or fields (``pgtrigger.ReadOnly``).
* Soft-deleting models (``pgtrigger.SoftDelete``).
* Snapshotting and tracking model changes (`django-pghistory `__).
* Enforcing field transitions (``pgtrigger.FSM``).
* Keeping a search vector updated for full-text search (``pgtrigger.UpdateSearchVector``).
* Building official interfaces
(e.g. enforcing use of ``User.objects.create_user`` and not
``User.objects.create``).
* Versioning models, mirroring fields, computing unique model hashes, and the list goes on...
All of these examples require no overridden methods, no base models, and no signal handling.
%package -n python3-django-pgtrigger
Summary: Postgres trigger support integrated with Django models.
Provides: python-django-pgtrigger
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-pgtrigger
Triggers can solve a variety of complex problems more reliably, performantly, and succinctly than application code.
For example,
* Protecting operations on rows or columns (``pgtrigger.Protect``).
* Making read-only models or fields (``pgtrigger.ReadOnly``).
* Soft-deleting models (``pgtrigger.SoftDelete``).
* Snapshotting and tracking model changes (`django-pghistory `__).
* Enforcing field transitions (``pgtrigger.FSM``).
* Keeping a search vector updated for full-text search (``pgtrigger.UpdateSearchVector``).
* Building official interfaces
(e.g. enforcing use of ``User.objects.create_user`` and not
``User.objects.create``).
* Versioning models, mirroring fields, computing unique model hashes, and the list goes on...
All of these examples require no overridden methods, no base models, and no signal handling.
%package help
Summary: Development documents and examples for django-pgtrigger
Provides: python3-django-pgtrigger-doc
%description help
Triggers can solve a variety of complex problems more reliably, performantly, and succinctly than application code.
For example,
* Protecting operations on rows or columns (``pgtrigger.Protect``).
* Making read-only models or fields (``pgtrigger.ReadOnly``).
* Soft-deleting models (``pgtrigger.SoftDelete``).
* Snapshotting and tracking model changes (`django-pghistory `__).
* Enforcing field transitions (``pgtrigger.FSM``).
* Keeping a search vector updated for full-text search (``pgtrigger.UpdateSearchVector``).
* Building official interfaces
(e.g. enforcing use of ``User.objects.create_user`` and not
``User.objects.create``).
* Versioning models, mirroring fields, computing unique model hashes, and the list goes on...
All of these examples require no overridden methods, no base models, and no signal handling.
%prep
%autosetup -n django-pgtrigger-4.6.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-pgtrigger -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 4.6.0-1
- Package Spec generated