%global _empty_manifest_terminate_build 0
Name:		python-synapse
Version:	2.127.0
Release:	1
Summary:	Synapse Intelligence Analysis Framework
License:	Apache License 2.0
URL:		https://github.com/vertexproject/synapse
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/8f/a2/3049f5f929e2f6c9fd38df439192017b0b903a0232f55d23211f817e54f2/synapse-2.127.0.tar.gz
BuildArch:	noarch

Requires:	python3-pyOpenSSL
Requires:	python3-cryptography
Requires:	python3-msgpack
Requires:	python3-xxhash
Requires:	python3-lmdb
Requires:	python3-tornado
Requires:	python3-regex
Requires:	python3-PyYAML
Requires:	python3-aiohttp
Requires:	python3-aiohttp-socks
Requires:	python3-aioimaplib
Requires:	python3-aiosmtplib
Requires:	python3-prompt-toolkit
Requires:	python3-lark
Requires:	python3-Pygments
Requires:	python3-packaging
Requires:	python3-fastjsonschema
Requires:	python3-stix2-validator
Requires:	python3-vcrpy
Requires:	python3-base58
Requires:	python3-bitcoinlib
Requires:	python3-pycryptodome
Requires:	python3-typing-extensions
Requires:	python3-scalecodec
Requires:	python3-cbor2
Requires:	python3-bech32
Requires:	python3-oauthlib
Requires:	python3-idna
Requires:	python3-dateutil
Requires:	python3-pytz
Requires:	python3-beautifulsoup4[html5lib]
Requires:	python3-pytest
Requires:	python3-autopep8
Requires:	python3-pytest-cov
Requires:	python3-pycodestyle
Requires:	python3-bump2version
Requires:	python3-pytest-xdist
Requires:	python3-coverage
Requires:	python3-nbconvert
Requires:	python3-jupyter-client
Requires:	python3-jupyter
Requires:	python3-hide-code
Requires:	python3-nbstripout
Requires:	python3-sphinx
Requires:	python3-sphinx-rtd-theme
Requires:	python3-sphinx-notfound-page
Requires:	python3-jinja2

%description
Synapse is a versatile central intelligence system created to support analyst teams in every stage of the intelligence life cycle.
|codecov|_ |circleci|_ |rtd|_

%package -n python3-synapse
Summary:	Synapse Intelligence Analysis Framework
Provides:	python-synapse
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-synapse
Synapse is a versatile central intelligence system created to support analyst teams in every stage of the intelligence life cycle.
|codecov|_ |circleci|_ |rtd|_

%package help
Summary:	Development documents and examples for synapse
Provides:	python3-synapse-doc
%description help
Synapse is a versatile central intelligence system created to support analyst teams in every stage of the intelligence life cycle.
|codecov|_ |circleci|_ |rtd|_

%prep
%autosetup -n synapse-2.127.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-synapse -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2.127.0-1
- Package Spec generated