%global _empty_manifest_terminate_build 0
Name:		python-isbnlib
Version:	3.10.13
Release:	1
Summary:	Extract, clean, transform, hyphenate and metadata for ISBNs (International Standard Book Number).
License:	LGPL v3
URL:		https://github.com/xlcnd/isbnlib
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/3e/14/d02ae3da42280a47e67712382add2cef9472faf652864e4443827bfc984e/isbnlib-3.10.13.tar.gz
BuildArch:	noarch


%description
``isbnlib`` is a (pure) python library that provides several
useful methods and functions to validate, clean, transform, hyphenate and
get metadata for ISBN strings.

%package -n python3-isbnlib
Summary:	Extract, clean, transform, hyphenate and metadata for ISBNs (International Standard Book Number).
Provides:	python-isbnlib
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-isbnlib
``isbnlib`` is a (pure) python library that provides several
useful methods and functions to validate, clean, transform, hyphenate and
get metadata for ISBN strings.

%package help
Summary:	Development documents and examples for isbnlib
Provides:	python3-isbnlib-doc
%description help
``isbnlib`` is a (pure) python library that provides several
useful methods and functions to validate, clean, transform, hyphenate and
get metadata for ISBN strings.

%prep
%autosetup -n isbnlib-3.10.13

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-isbnlib -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 3.10.13-1
- Package Spec generated