%global _empty_manifest_terminate_build 0
Name:		python-sentinel
Version:	1.0.0
Release:	1
Summary:	Create sentinel objects, akin to None, NotImplemented, Ellipsis
License:	MIT
URL:		https://github.com/eddieantonio/sentinel
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/4a/d8/49115169583d02b38e7d93909a474c7ed0863f7d4df27095588344f2e66a/sentinel-1.0.0.tar.gz
BuildArch:	noarch

Requires:	python3-varname

%description
Basic features::
   pip install sentinel
with extra magic features powered by python-varname_::
   pip install 'sentinel[varname]'

%package -n python3-sentinel
Summary:	Create sentinel objects, akin to None, NotImplemented, Ellipsis
Provides:	python-sentinel
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sentinel
Basic features::
   pip install sentinel
with extra magic features powered by python-varname_::
   pip install 'sentinel[varname]'

%package help
Summary:	Development documents and examples for sentinel
Provides:	python3-sentinel-doc
%description help
Basic features::
   pip install sentinel
with extra magic features powered by python-varname_::
   pip install 'sentinel[varname]'

%prep
%autosetup -n sentinel-1.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sentinel -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
- Package Spec generated