%global _empty_manifest_terminate_build 0
Name: python-deepecho
Version: 0.4.0
Release: 1
Summary: Create sequential synthetic data of mixed types using a GAN.
License: BSL-1.1
URL: https://github.com/sdv-dev/DeepEcho
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/98/84/7040528e28a57d7d2e6d28b40896df82501a38fa179f32d289ae974f1552/deepecho-0.4.0.tar.gz
BuildArch: noarch
Requires: python3-tqdm
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-torch
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-torch
Requires: python3-setuptools
Requires: python3-bumpversion
Requires: python3-pip
Requires: python3-watchdog
Requires: python3-flake8
Requires: python3-flake8-absolute-import
Requires: python3-flake8-docstrings
Requires: python3-flake8-sfs
Requires: python3-isort
Requires: python3-pylint
Requires: python3-flake8-builtins
Requires: python3-flake8-debugger
Requires: python3-flake8-mock
Requires: python3-dlint
Requires: python3-flake8-eradicate
Requires: python3-flake8-mutable
Requires: python3-flake8-fixme
Requires: python3-flake8-multiline-containers
Requires: python3-flake8-quotes
Requires: python3-flake8-variables-names
Requires: python3-pep8-naming
Requires: python3-flake8-expression-complexity
Requires: python3-flake8-print
Requires: python3-autoflake
Requires: python3-autopep8
Requires: python3-twine
Requires: python3-wheel
Requires: python3-coverage
Requires: python3-tox
Requires: python3-invoke
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-rerunfailures
Requires: python3-jupyter
Requires: python3-rundoc
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-rerunfailures
Requires: python3-jupyter
Requires: python3-rundoc
%description
[The Synthetic Data Vault Project](https://sdv.dev) was first created at MIT's [Data to AI Lab](
https://dai.lids.mit.edu/) in 2016. After 4 years of research and traction with enterprise, we
created [DataCebo](https://datacebo.com) in 2020 with the goal of growing the project.
Today, DataCebo is the proud developer of SDV, the largest ecosystem for
synthetic data generation & evaluation. It is home to multiple libraries that support synthetic
data, including:
* 🔄 Data discovery & transformation. Reverse the transforms to reproduce realistic data.
* 🧠Multiple machine learning models -- ranging from Copulas to Deep Learning -- to create tabular,
multi table and time series data.
* 📊 Measuring quality and privacy of synthetic data, and comparing different synthetic data
generation models.
[Get started using the SDV package](https://sdv.dev/SDV/getting_started/install.html) -- a fully
integrated solution and your one-stop shop for synthetic data. Or, use the standalone libraries
for specific needs.
# History
## 0.3.0 - 2021-11-15
This release adds support for Python 3.9 and updates dependencies to ensure compatibility with the rest
of the SDV ecosystem.
* Add support for Python 3.9 - Issue [#41](https://github.com/sdv-dev/DeepEcho/issues/41) by @fealho
* Add pip check to CI workflows internal improvements - Issue [#39](https://github.com/sdv-dev/DeepEcho/issues/39) by @pvk-developer
* Add support for pylint>2.7.2 housekeeping - Issue [#33](https://github.com/sdv-dev/DeepEcho/issues/33) by @fealho
* Add support for torch>=1.8 housekeeping - Issue [#32](https://github.com/sdv-dev/DeepEcho/issues/32) by @fealho
## 0.2.1 - 2021-10-12
This release fixes a bug with how DeepEcho handles NaN values.
* Handling NaN's bug - Issue [#35](https://github.com/sdv-dev/DeepEcho/issues/35) by @fealho
## 0.2.0 - 2021-02-24
Maintenance release to update dependencies and ensure compatibility with the rest
of the SDV ecosystem libraries.
## 0.1.4 - 2020-10-16
Minor maintenance version to update dependencies and documentation, and
also make the demo data loading function parse dates properly.
## 0.1.3 - 2020-10-16
This version includes several minor improvements to the PAR model and the
way the sequences are generated:
* Sequences can now be generated without dropping the sequence index.
* The PAR model learns the min and max length of the sequence from the input data.
* NaN values are properly supported for both categorical and numerical columns.
* NaN values are generated for numerical columns only if there were NaNs in the input data.
* Constant columns can now be modeled.
## 0.1.2 - 2020-09-15
Add BasicGAN Model and additional benchmarking results.
## 0.1.1 - 2020-08-15
This release includes a few new features to make DeepEcho work on more types of datasets
as well as to making it easier to add new datasets to the benchmarking framework.
* Add `segment_size` and `sequence_index` arguments to `fit` method.
* Add `sequence_length` as an optional argument to `sample` and `sample_sequence` methods.
* Update the Dataset storage format to add `sequence_index` and versioning.
* Separate the sequence assembling process in its own `deepecho.sequences` module.
* Add function `make_dataset` to create a dataset from a dataframe and just a few column names.
* Add notebook tutorial to show how to create a datasets and use them.
## 0.1.0 - 2020-08-11
First release.
Included Features:
* PARModel
* Demo dataset and tutorials
* Benchmarking Framework
* Support and instructions for benchmarking on a Kubernetes cluster.
%package -n python3-deepecho
Summary: Create sequential synthetic data of mixed types using a GAN.
Provides: python-deepecho
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-deepecho
[The Synthetic Data Vault Project](https://sdv.dev) was first created at MIT's [Data to AI Lab](
https://dai.lids.mit.edu/) in 2016. After 4 years of research and traction with enterprise, we
created [DataCebo](https://datacebo.com) in 2020 with the goal of growing the project.
Today, DataCebo is the proud developer of SDV, the largest ecosystem for
synthetic data generation & evaluation. It is home to multiple libraries that support synthetic
data, including:
* 🔄 Data discovery & transformation. Reverse the transforms to reproduce realistic data.
* 🧠Multiple machine learning models -- ranging from Copulas to Deep Learning -- to create tabular,
multi table and time series data.
* 📊 Measuring quality and privacy of synthetic data, and comparing different synthetic data
generation models.
[Get started using the SDV package](https://sdv.dev/SDV/getting_started/install.html) -- a fully
integrated solution and your one-stop shop for synthetic data. Or, use the standalone libraries
for specific needs.
# History
## 0.3.0 - 2021-11-15
This release adds support for Python 3.9 and updates dependencies to ensure compatibility with the rest
of the SDV ecosystem.
* Add support for Python 3.9 - Issue [#41](https://github.com/sdv-dev/DeepEcho/issues/41) by @fealho
* Add pip check to CI workflows internal improvements - Issue [#39](https://github.com/sdv-dev/DeepEcho/issues/39) by @pvk-developer
* Add support for pylint>2.7.2 housekeeping - Issue [#33](https://github.com/sdv-dev/DeepEcho/issues/33) by @fealho
* Add support for torch>=1.8 housekeeping - Issue [#32](https://github.com/sdv-dev/DeepEcho/issues/32) by @fealho
## 0.2.1 - 2021-10-12
This release fixes a bug with how DeepEcho handles NaN values.
* Handling NaN's bug - Issue [#35](https://github.com/sdv-dev/DeepEcho/issues/35) by @fealho
## 0.2.0 - 2021-02-24
Maintenance release to update dependencies and ensure compatibility with the rest
of the SDV ecosystem libraries.
## 0.1.4 - 2020-10-16
Minor maintenance version to update dependencies and documentation, and
also make the demo data loading function parse dates properly.
## 0.1.3 - 2020-10-16
This version includes several minor improvements to the PAR model and the
way the sequences are generated:
* Sequences can now be generated without dropping the sequence index.
* The PAR model learns the min and max length of the sequence from the input data.
* NaN values are properly supported for both categorical and numerical columns.
* NaN values are generated for numerical columns only if there were NaNs in the input data.
* Constant columns can now be modeled.
## 0.1.2 - 2020-09-15
Add BasicGAN Model and additional benchmarking results.
## 0.1.1 - 2020-08-15
This release includes a few new features to make DeepEcho work on more types of datasets
as well as to making it easier to add new datasets to the benchmarking framework.
* Add `segment_size` and `sequence_index` arguments to `fit` method.
* Add `sequence_length` as an optional argument to `sample` and `sample_sequence` methods.
* Update the Dataset storage format to add `sequence_index` and versioning.
* Separate the sequence assembling process in its own `deepecho.sequences` module.
* Add function `make_dataset` to create a dataset from a dataframe and just a few column names.
* Add notebook tutorial to show how to create a datasets and use them.
## 0.1.0 - 2020-08-11
First release.
Included Features:
* PARModel
* Demo dataset and tutorials
* Benchmarking Framework
* Support and instructions for benchmarking on a Kubernetes cluster.
%package help
Summary: Development documents and examples for deepecho
Provides: python3-deepecho-doc
%description help
[The Synthetic Data Vault Project](https://sdv.dev) was first created at MIT's [Data to AI Lab](
https://dai.lids.mit.edu/) in 2016. After 4 years of research and traction with enterprise, we
created [DataCebo](https://datacebo.com) in 2020 with the goal of growing the project.
Today, DataCebo is the proud developer of SDV, the largest ecosystem for
synthetic data generation & evaluation. It is home to multiple libraries that support synthetic
data, including:
* 🔄 Data discovery & transformation. Reverse the transforms to reproduce realistic data.
* 🧠Multiple machine learning models -- ranging from Copulas to Deep Learning -- to create tabular,
multi table and time series data.
* 📊 Measuring quality and privacy of synthetic data, and comparing different synthetic data
generation models.
[Get started using the SDV package](https://sdv.dev/SDV/getting_started/install.html) -- a fully
integrated solution and your one-stop shop for synthetic data. Or, use the standalone libraries
for specific needs.
# History
## 0.3.0 - 2021-11-15
This release adds support for Python 3.9 and updates dependencies to ensure compatibility with the rest
of the SDV ecosystem.
* Add support for Python 3.9 - Issue [#41](https://github.com/sdv-dev/DeepEcho/issues/41) by @fealho
* Add pip check to CI workflows internal improvements - Issue [#39](https://github.com/sdv-dev/DeepEcho/issues/39) by @pvk-developer
* Add support for pylint>2.7.2 housekeeping - Issue [#33](https://github.com/sdv-dev/DeepEcho/issues/33) by @fealho
* Add support for torch>=1.8 housekeeping - Issue [#32](https://github.com/sdv-dev/DeepEcho/issues/32) by @fealho
## 0.2.1 - 2021-10-12
This release fixes a bug with how DeepEcho handles NaN values.
* Handling NaN's bug - Issue [#35](https://github.com/sdv-dev/DeepEcho/issues/35) by @fealho
## 0.2.0 - 2021-02-24
Maintenance release to update dependencies and ensure compatibility with the rest
of the SDV ecosystem libraries.
## 0.1.4 - 2020-10-16
Minor maintenance version to update dependencies and documentation, and
also make the demo data loading function parse dates properly.
## 0.1.3 - 2020-10-16
This version includes several minor improvements to the PAR model and the
way the sequences are generated:
* Sequences can now be generated without dropping the sequence index.
* The PAR model learns the min and max length of the sequence from the input data.
* NaN values are properly supported for both categorical and numerical columns.
* NaN values are generated for numerical columns only if there were NaNs in the input data.
* Constant columns can now be modeled.
## 0.1.2 - 2020-09-15
Add BasicGAN Model and additional benchmarking results.
## 0.1.1 - 2020-08-15
This release includes a few new features to make DeepEcho work on more types of datasets
as well as to making it easier to add new datasets to the benchmarking framework.
* Add `segment_size` and `sequence_index` arguments to `fit` method.
* Add `sequence_length` as an optional argument to `sample` and `sample_sequence` methods.
* Update the Dataset storage format to add `sequence_index` and versioning.
* Separate the sequence assembling process in its own `deepecho.sequences` module.
* Add function `make_dataset` to create a dataset from a dataframe and just a few column names.
* Add notebook tutorial to show how to create a datasets and use them.
## 0.1.0 - 2020-08-11
First release.
Included Features:
* PARModel
* Demo dataset and tutorials
* Benchmarking Framework
* Support and instructions for benchmarking on a Kubernetes cluster.
%prep
%autosetup -n deepecho-0.4.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-deepecho -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.4.0-1
- Package Spec generated