%global _empty_manifest_terminate_build 0
Name: python-riotwatcher
Version: 3.2.4
Release: 1
Summary: RiotWatcher is a thin wrapper on top of the Riot Games API for League of Legends.
License: MIT
URL: https://github.com/pseudonym117/Riot-Watcher
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2c/f1/176ca257e62bfd51b53dfd42ab2de87515de32e0b187290c5ad9c4d8bc30/riotwatcher-3.2.4.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-coverage
Requires: python3-pre-commit
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-tox
%description
|pypi| |docs| |coverage| |black|
Check for full (read: slightly better) documentation `here `__!
RiotWatcher is a thin wrapper on top of the `Riot Games API for League
of Legends `__. All public methods as
of 10/29/2022 are supported in full.
RiotWatcher by default supports a naive rate limiter. This rate limiter will
try to stop you from making too many requests, and in a single threaded test
environment does this rather well. In a multithreaded environment, you may
still get some 429 errors. 429 errors are currently NOT retried for you.
%package -n python3-riotwatcher
Summary: RiotWatcher is a thin wrapper on top of the Riot Games API for League of Legends.
Provides: python-riotwatcher
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-riotwatcher
|pypi| |docs| |coverage| |black|
Check for full (read: slightly better) documentation `here `__!
RiotWatcher is a thin wrapper on top of the `Riot Games API for League
of Legends `__. All public methods as
of 10/29/2022 are supported in full.
RiotWatcher by default supports a naive rate limiter. This rate limiter will
try to stop you from making too many requests, and in a single threaded test
environment does this rather well. In a multithreaded environment, you may
still get some 429 errors. 429 errors are currently NOT retried for you.
%package help
Summary: Development documents and examples for riotwatcher
Provides: python3-riotwatcher-doc
%description help
|pypi| |docs| |coverage| |black|
Check for full (read: slightly better) documentation `here `__!
RiotWatcher is a thin wrapper on top of the `Riot Games API for League
of Legends `__. All public methods as
of 10/29/2022 are supported in full.
RiotWatcher by default supports a naive rate limiter. This rate limiter will
try to stop you from making too many requests, and in a single threaded test
environment does this rather well. In a multithreaded environment, you may
still get some 429 errors. 429 errors are currently NOT retried for you.
%prep
%autosetup -n riotwatcher-3.2.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-riotwatcher -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 3.2.4-1
- Package Spec generated