%global _empty_manifest_terminate_build 0
Name:		python-aiohttp-requests
Version:	0.1.3
Release:	1
Summary:	A thin wrapper for aiohttp client with Requests simplicity
License:	MIT
URL:		https://github.com/maxzheng/aiohttp-requests
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/23/7a/f89df8a0a00a56b025f552932714ec3f3bac798359474a37937741fe9844/aiohttp-requests-0.1.3.tar.gz
BuildArch:	noarch

Requires:	python3-aiohttp
Requires:	python3-cchardet
Requires:	python3-aiodns

%description
Behold, the power of `aiohttp <https://aiohttp.readthedocs.io>`_ client with `Requests <http://docs.python-requests.org/>`_ simplicity:
    >>> import asyncio
    >>>
    >>> import aiohttp
    >>> from aiohttp_requests import requests
    >>>
    >>> async def main():
    >>> loop = asyncio.get_event_loop()
    >>> r, text, json = loop.run_until_complete(main())
    >>>
    >>> r
    <ClientResponse(https://api.github.com/user) [200 OK]>
    >>> r.status
    200
    >>> r.headers['Content-Type']
    'application/json; charset=utf-8'
    >>> r.get_encoding()
    'utf-8'
    >>> text
    '{"login":"...'
    >>> json
    {'login': 'user', 'public_repos': 28, ...}
The `requests` object is just proxying `get` and any other HTTP verb methods to `aiohttp.ClientSession <http://aiohttp.readthedocs.io/en/v3.0.1/client_reference.html#client-session>`_, which returns `aiohttp.ClientResponse <http://aiohttp.readthedocs.io/en/v3.0.1/client_reference.html#response-object>`_. To do anything else, just read the `aiohttp <https://aiohttp.readthedocs.io>`_ doc.

%package -n python3-aiohttp-requests
Summary:	A thin wrapper for aiohttp client with Requests simplicity
Provides:	python-aiohttp-requests
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-aiohttp-requests
Behold, the power of `aiohttp <https://aiohttp.readthedocs.io>`_ client with `Requests <http://docs.python-requests.org/>`_ simplicity:
    >>> import asyncio
    >>>
    >>> import aiohttp
    >>> from aiohttp_requests import requests
    >>>
    >>> async def main():
    >>> loop = asyncio.get_event_loop()
    >>> r, text, json = loop.run_until_complete(main())
    >>>
    >>> r
    <ClientResponse(https://api.github.com/user) [200 OK]>
    >>> r.status
    200
    >>> r.headers['Content-Type']
    'application/json; charset=utf-8'
    >>> r.get_encoding()
    'utf-8'
    >>> text
    '{"login":"...'
    >>> json
    {'login': 'user', 'public_repos': 28, ...}
The `requests` object is just proxying `get` and any other HTTP verb methods to `aiohttp.ClientSession <http://aiohttp.readthedocs.io/en/v3.0.1/client_reference.html#client-session>`_, which returns `aiohttp.ClientResponse <http://aiohttp.readthedocs.io/en/v3.0.1/client_reference.html#response-object>`_. To do anything else, just read the `aiohttp <https://aiohttp.readthedocs.io>`_ doc.

%package help
Summary:	Development documents and examples for aiohttp-requests
Provides:	python3-aiohttp-requests-doc
%description help
Behold, the power of `aiohttp <https://aiohttp.readthedocs.io>`_ client with `Requests <http://docs.python-requests.org/>`_ simplicity:
    >>> import asyncio
    >>>
    >>> import aiohttp
    >>> from aiohttp_requests import requests
    >>>
    >>> async def main():
    >>> loop = asyncio.get_event_loop()
    >>> r, text, json = loop.run_until_complete(main())
    >>>
    >>> r
    <ClientResponse(https://api.github.com/user) [200 OK]>
    >>> r.status
    200
    >>> r.headers['Content-Type']
    'application/json; charset=utf-8'
    >>> r.get_encoding()
    'utf-8'
    >>> text
    '{"login":"...'
    >>> json
    {'login': 'user', 'public_repos': 28, ...}
The `requests` object is just proxying `get` and any other HTTP verb methods to `aiohttp.ClientSession <http://aiohttp.readthedocs.io/en/v3.0.1/client_reference.html#client-session>`_, which returns `aiohttp.ClientResponse <http://aiohttp.readthedocs.io/en/v3.0.1/client_reference.html#response-object>`_. To do anything else, just read the `aiohttp <https://aiohttp.readthedocs.io>`_ doc.

%prep
%autosetup -n aiohttp-requests-0.1.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-aiohttp-requests -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.3-1
- Package Spec generated