%global _empty_manifest_terminate_build 0
Name:		python-meval
Version:	2.5
Release:	1
Summary:	Performs async evaluations of strings
License:	MIT License
URL:		https://github.com/penn5/meval
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/a0/58/2bfffe5a6a1d3d7e9fe2888807a11d220f6cda11af0a41db1170ca9ae6b7/meval-2.5.tar.gz
BuildArch:	noarch


%description
# meval

Evaluates python strings as async code

## Usage

```python
# inside an `async def`
from meval import meval
await meval("await thing", globals(), thing=my_function(arg=1))
```

## License

MIT




%package -n python3-meval
Summary:	Performs async evaluations of strings
Provides:	python-meval
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-meval
# meval

Evaluates python strings as async code

## Usage

```python
# inside an `async def`
from meval import meval
await meval("await thing", globals(), thing=my_function(arg=1))
```

## License

MIT




%package help
Summary:	Development documents and examples for meval
Provides:	python3-meval-doc
%description help
# meval

Evaluates python strings as async code

## Usage

```python
# inside an `async def`
from meval import meval
await meval("await thing", globals(), thing=my_function(arg=1))
```

## License

MIT




%prep
%autosetup -n meval-2.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-meval -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2.5-1
- Package Spec generated