%global _empty_manifest_terminate_build 0
Name:		python-types-contextvars
Version:	2.4.7.2
Release:	1
Summary:	Typing stubs for contextvars
License:	Apache-2.0 license
URL:		https://github.com/python/typeshed
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/07/d9/b6393e103223bb3c4faa2e5449bc5e6ce4c73b5ac329a7d5d4761e74fb6c/types-contextvars-2.4.7.2.tar.gz
BuildArch:	noarch


%description
## Typing stubs for contextvars

This is a PEP 561 type stub package for the `contextvars` package. It
can be used by type-checking tools like
[mypy](https://github.com/python/mypy/),
[pyright](https://github.com/microsoft/pyright),
[pytype](https://github.com/google/pytype/),
PyCharm, etc. to check code that uses
`contextvars`. The source for this package can be found at
https://github.com/python/typeshed/tree/main/stubs/contextvars. All fixes for
types and metadata should be contributed there.

See https://github.com/python/typeshed/blob/main/README.md for more details.
This package was generated from typeshed commit `6fd7e36e80e0448d9199d62d582c659c147be149`.


%package -n python3-types-contextvars
Summary:	Typing stubs for contextvars
Provides:	python-types-contextvars
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-types-contextvars
## Typing stubs for contextvars

This is a PEP 561 type stub package for the `contextvars` package. It
can be used by type-checking tools like
[mypy](https://github.com/python/mypy/),
[pyright](https://github.com/microsoft/pyright),
[pytype](https://github.com/google/pytype/),
PyCharm, etc. to check code that uses
`contextvars`. The source for this package can be found at
https://github.com/python/typeshed/tree/main/stubs/contextvars. All fixes for
types and metadata should be contributed there.

See https://github.com/python/typeshed/blob/main/README.md for more details.
This package was generated from typeshed commit `6fd7e36e80e0448d9199d62d582c659c147be149`.


%package help
Summary:	Development documents and examples for types-contextvars
Provides:	python3-types-contextvars-doc
%description help
## Typing stubs for contextvars

This is a PEP 561 type stub package for the `contextvars` package. It
can be used by type-checking tools like
[mypy](https://github.com/python/mypy/),
[pyright](https://github.com/microsoft/pyright),
[pytype](https://github.com/google/pytype/),
PyCharm, etc. to check code that uses
`contextvars`. The source for this package can be found at
https://github.com/python/typeshed/tree/main/stubs/contextvars. All fixes for
types and metadata should be contributed there.

See https://github.com/python/typeshed/blob/main/README.md for more details.
This package was generated from typeshed commit `6fd7e36e80e0448d9199d62d582c659c147be149`.


%prep
%autosetup -n types-contextvars-2.4.7.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-types-contextvars -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2.4.7.2-1
- Package Spec generated