%global _empty_manifest_terminate_build 0
Name: python-Flask-Env
Version: 2.0.0
Release: 1
Summary: Easily set Flask settings from environment variables
License: MIT
URL: https://github.com/brettlangdon/flask-env
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/92/c4/2146ffb5dbbee8718e35dbcda74b416a6a986bf06e4f408a2ce751b6b248/Flask-Env-2.0.0.tar.gz
BuildArch: noarch
%description
Easily set `Flask `_ settings from environment variables.
The reason for using :code:`flask-env` is to be able to follow the `12-factor app `_ suggestions for configuring your application.
With :code:`flask-env` you can define your default configuration options in code and very easily override via environment variables.
Installation
~~~~~~~~~~~~
pip install Flask-Env
Usage
~~~~~
With :code:`flask-env` you will define your configuration as an object and load it into your Flask application via `app.config.from_object `_ method.
%package -n python3-Flask-Env
Summary: Easily set Flask settings from environment variables
Provides: python-Flask-Env
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Flask-Env
Easily set `Flask `_ settings from environment variables.
The reason for using :code:`flask-env` is to be able to follow the `12-factor app `_ suggestions for configuring your application.
With :code:`flask-env` you can define your default configuration options in code and very easily override via environment variables.
Installation
~~~~~~~~~~~~
pip install Flask-Env
Usage
~~~~~
With :code:`flask-env` you will define your configuration as an object and load it into your Flask application via `app.config.from_object `_ method.
%package help
Summary: Development documents and examples for Flask-Env
Provides: python3-Flask-Env-doc
%description help
Easily set `Flask `_ settings from environment variables.
The reason for using :code:`flask-env` is to be able to follow the `12-factor app `_ suggestions for configuring your application.
With :code:`flask-env` you can define your default configuration options in code and very easily override via environment variables.
Installation
~~~~~~~~~~~~
pip install Flask-Env
Usage
~~~~~
With :code:`flask-env` you will define your configuration as an object and load it into your Flask application via `app.config.from_object `_ method.
%prep
%autosetup -n Flask-Env-2.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Flask-Env -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 2.0.0-1
- Package Spec generated