%global _empty_manifest_terminate_build 0
Name: python-Amsync
Version: 0.0.53
Release: 1
Summary: An async library to easily create bots for the amino.
License: MIT
URL: https://github.com/ellandor/Amsync
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/09/61/05dc62c9f7c79f72391fdd967aae81d7953ebbcc489a888168a9ffeac2e1/Amsync-0.0.53.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-ujson
Requires: python3-pybase64
Requires: python3-peewee
Requires: python3-dotenv
Requires: python3-pillow
Requires: python3-colorama
Requires: python3-filetype
%description
# Amsync
Created with the aim that, anyone with basic knowledge of python, create any bot without much difficulty
# Installation
```
pip install Amsync
```
# Minimal example
```py
from amsync import Bot, Msg
bot = Bot('email', 'password', prefix='/')
@bot.on()
async def ready():
print('Ready')
@bot.add()
async def hi(m: Msg):
await bot.send(f'Hi {m.nickname}')
bot.run()
```
**[Incredible documentation to create beautiful bots](https://github.com/ellandor/Amsync/blob/main/docs/docs.md)**
%package -n python3-Amsync
Summary: An async library to easily create bots for the amino.
Provides: python-Amsync
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Amsync
# Amsync
Created with the aim that, anyone with basic knowledge of python, create any bot without much difficulty
# Installation
```
pip install Amsync
```
# Minimal example
```py
from amsync import Bot, Msg
bot = Bot('email', 'password', prefix='/')
@bot.on()
async def ready():
print('Ready')
@bot.add()
async def hi(m: Msg):
await bot.send(f'Hi {m.nickname}')
bot.run()
```
**[Incredible documentation to create beautiful bots](https://github.com/ellandor/Amsync/blob/main/docs/docs.md)**
%package help
Summary: Development documents and examples for Amsync
Provides: python3-Amsync-doc
%description help
# Amsync
Created with the aim that, anyone with basic knowledge of python, create any bot without much difficulty
# Installation
```
pip install Amsync
```
# Minimal example
```py
from amsync import Bot, Msg
bot = Bot('email', 'password', prefix='/')
@bot.on()
async def ready():
print('Ready')
@bot.add()
async def hi(m: Msg):
await bot.send(f'Hi {m.nickname}')
bot.run()
```
**[Incredible documentation to create beautiful bots](https://github.com/ellandor/Amsync/blob/main/docs/docs.md)**
%prep
%autosetup -n Amsync-0.0.53
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Amsync -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.0.53-1
- Package Spec generated