%global _empty_manifest_terminate_build 0
Name:		python-Token
Version:	1.8.6
Release:	1
Summary:	Token client to REST Apis
License:	UNKNOWN
URL:		UNKNOWN
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/97/f6/45ef88979836ff6100dafcbbe6ac5ad7fc444ba54f52bf730054abb72320/Token-1.8.6.tar.gz
BuildArch:	noarch


%description
Interact with Token REST Apis

%package -n python3-Token
Summary:	Token client to REST Apis
Provides:	python-Token
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Token
Interact with Token REST Apis

%package help
Summary:	Development documents and examples for Token
Provides:	python3-Token-doc
%description help
Interact with Token REST Apis

%prep
%autosetup -n Token-1.8.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Token -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 1.8.6-1
- Package Spec generated