%global _empty_manifest_terminate_build 0
Name:		python-dynesty
Version:	2.1.0
Release:	1
Summary:	A dynamic nested sampling package for computing Bayesian posteriors and evidences.
License:	MIT
URL:		https://github.com/joshspeagle/dynesty
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/a8/6f/c4d4a7840fa60054e3156ee4985c6566ae0069afdeca1f12ec24cb0f5ed2/dynesty-2.1.0.tar.gz
BuildArch:	noarch


%description
![dynesty in action](https://github.com/joshspeagle/dynesty/blob/master/docs/images/title.gif)
A Dynamic Nested Sampling package for computing Bayesian posteriors and
evidences. Pure Python. MIT license.
### Documentation
Documentation can be found [here](https://dynesty.readthedocs.io).
### Installation
The most stable release of `dynesty` can be installed
through [pip](https://pip.pypa.io/en/stable) via
```
pip install dynesty
```
The current (less stable) development version can be installed by running
```
python setup.py install
```
from inside the repository.
### Demos
Several Jupyter notebooks that demonstrate most of the available features
of the code can be found 
[here](https://github.com/joshspeagle/dynesty/tree/master/demos).
### Attribution
If you find the package useful in your research, please cite at least *both* of these references:
* The original paper [Speagle (2020)](https://ui.adsabs.harvard.edu/abs/2020MNRAS.493.3132S/abstract)
* The python implementation [Koposov et al. (2023)](https://doi.org/10.5281/zenodo.3348367) (the citation info is at the bottom of the page on the right)
and ideally also papers describing the underlying methods (see the [documentation](https://dynesty.readthedocs.io/en/latest/references.html) for more details)
### Reporting issues
If you want to report issues, or have questions, please do that on [github](https://github.com/joshspeagle/dynesty/issues).
### Contributing
Patches and contributions are very welcome! Please see [CONTRIBUTING.md](https://github.com/joshspeagle/dynesty/blob/master/CONTRIBUTING.md) for more details.

%package -n python3-dynesty
Summary:	A dynamic nested sampling package for computing Bayesian posteriors and evidences.
Provides:	python-dynesty
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-dynesty
![dynesty in action](https://github.com/joshspeagle/dynesty/blob/master/docs/images/title.gif)
A Dynamic Nested Sampling package for computing Bayesian posteriors and
evidences. Pure Python. MIT license.
### Documentation
Documentation can be found [here](https://dynesty.readthedocs.io).
### Installation
The most stable release of `dynesty` can be installed
through [pip](https://pip.pypa.io/en/stable) via
```
pip install dynesty
```
The current (less stable) development version can be installed by running
```
python setup.py install
```
from inside the repository.
### Demos
Several Jupyter notebooks that demonstrate most of the available features
of the code can be found 
[here](https://github.com/joshspeagle/dynesty/tree/master/demos).
### Attribution
If you find the package useful in your research, please cite at least *both* of these references:
* The original paper [Speagle (2020)](https://ui.adsabs.harvard.edu/abs/2020MNRAS.493.3132S/abstract)
* The python implementation [Koposov et al. (2023)](https://doi.org/10.5281/zenodo.3348367) (the citation info is at the bottom of the page on the right)
and ideally also papers describing the underlying methods (see the [documentation](https://dynesty.readthedocs.io/en/latest/references.html) for more details)
### Reporting issues
If you want to report issues, or have questions, please do that on [github](https://github.com/joshspeagle/dynesty/issues).
### Contributing
Patches and contributions are very welcome! Please see [CONTRIBUTING.md](https://github.com/joshspeagle/dynesty/blob/master/CONTRIBUTING.md) for more details.

%package help
Summary:	Development documents and examples for dynesty
Provides:	python3-dynesty-doc
%description help
![dynesty in action](https://github.com/joshspeagle/dynesty/blob/master/docs/images/title.gif)
A Dynamic Nested Sampling package for computing Bayesian posteriors and
evidences. Pure Python. MIT license.
### Documentation
Documentation can be found [here](https://dynesty.readthedocs.io).
### Installation
The most stable release of `dynesty` can be installed
through [pip](https://pip.pypa.io/en/stable) via
```
pip install dynesty
```
The current (less stable) development version can be installed by running
```
python setup.py install
```
from inside the repository.
### Demos
Several Jupyter notebooks that demonstrate most of the available features
of the code can be found 
[here](https://github.com/joshspeagle/dynesty/tree/master/demos).
### Attribution
If you find the package useful in your research, please cite at least *both* of these references:
* The original paper [Speagle (2020)](https://ui.adsabs.harvard.edu/abs/2020MNRAS.493.3132S/abstract)
* The python implementation [Koposov et al. (2023)](https://doi.org/10.5281/zenodo.3348367) (the citation info is at the bottom of the page on the right)
and ideally also papers describing the underlying methods (see the [documentation](https://dynesty.readthedocs.io/en/latest/references.html) for more details)
### Reporting issues
If you want to report issues, or have questions, please do that on [github](https://github.com/joshspeagle/dynesty/issues).
### Contributing
Patches and contributions are very welcome! Please see [CONTRIBUTING.md](https://github.com/joshspeagle/dynesty/blob/master/CONTRIBUTING.md) for more details.

%prep
%autosetup -n dynesty-2.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-dynesty -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.0-1
- Package Spec generated