%global _empty_manifest_terminate_build 0
Name:		python-biscuits
Version:	0.3.0
Release:	1
Summary:	Fast and tasty cookies handling.
License:	MIT
URL:		https://github.com/pyrates/biscuits
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/84/9d/e69b0e01b21d73d1997d1065bafb54d218234114c82eb49e4e5703bfac8a/biscuits-0.3.0.tar.gz
BuildArch:	noarch


%description
# Biscuits

Low level API for handling cookies server side.


## Install

    pip install biscuits


## API

    # Parse a "Cookie:" header value:
    from biscuits import parse
    parse('some=value; and=more')
    > {'some': 'value', 'and': 'more'}

    # Generate a "Set-Cookie:" header value:
    from biscuits import Cookie
    cookie = Cookie(name='foo', value='bar', domain='www.example.org')
    str(cookie)
    > "foo=bar; Domain=www.example.org; Path=/"


## Building from source

    pip install cython
    make compile
    python setup.py develop

## Testing

    make test

## Benchmark

![benchmark](benchmark.png)

See [Benchmark](https://github.com/pyrates/biscuits/wiki/Benchmark) for more
details.


## Changelog

### 0.2

- unescape antislash when parsing to be consistent with quoting (cf #3)
- unescape octal ascii when parsing to be consistent with quoting (cf #4)

### 0.3

- add support for the SameSite attribute (cf #8)

%package -n python3-biscuits
Summary:	Fast and tasty cookies handling.
Provides:	python-biscuits
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-biscuits
# Biscuits

Low level API for handling cookies server side.


## Install

    pip install biscuits


## API

    # Parse a "Cookie:" header value:
    from biscuits import parse
    parse('some=value; and=more')
    > {'some': 'value', 'and': 'more'}

    # Generate a "Set-Cookie:" header value:
    from biscuits import Cookie
    cookie = Cookie(name='foo', value='bar', domain='www.example.org')
    str(cookie)
    > "foo=bar; Domain=www.example.org; Path=/"


## Building from source

    pip install cython
    make compile
    python setup.py develop

## Testing

    make test

## Benchmark

![benchmark](benchmark.png)

See [Benchmark](https://github.com/pyrates/biscuits/wiki/Benchmark) for more
details.


## Changelog

### 0.2

- unescape antislash when parsing to be consistent with quoting (cf #3)
- unescape octal ascii when parsing to be consistent with quoting (cf #4)

### 0.3

- add support for the SameSite attribute (cf #8)

%package help
Summary:	Development documents and examples for biscuits
Provides:	python3-biscuits-doc
%description help
# Biscuits

Low level API for handling cookies server side.


## Install

    pip install biscuits


## API

    # Parse a "Cookie:" header value:
    from biscuits import parse
    parse('some=value; and=more')
    > {'some': 'value', 'and': 'more'}

    # Generate a "Set-Cookie:" header value:
    from biscuits import Cookie
    cookie = Cookie(name='foo', value='bar', domain='www.example.org')
    str(cookie)
    > "foo=bar; Domain=www.example.org; Path=/"


## Building from source

    pip install cython
    make compile
    python setup.py develop

## Testing

    make test

## Benchmark

![benchmark](benchmark.png)

See [Benchmark](https://github.com/pyrates/biscuits/wiki/Benchmark) for more
details.


## Changelog

### 0.2

- unescape antislash when parsing to be consistent with quoting (cf #3)
- unescape octal ascii when parsing to be consistent with quoting (cf #4)

### 0.3

- add support for the SameSite attribute (cf #8)

%prep
%autosetup -n biscuits-0.3.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-biscuits -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0-1
- Package Spec generated