%global _empty_manifest_terminate_build 0
Name:		python-django-debreach
Version:	2.1.0
Release:	1
Summary:	Adds middleware to give some added protection against the BREACH attack in Django.
License:	BSD License
URL:		http://github.com/lpomfrey/django-debreach
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/1f/1a/2bc5970d6b848c7ff4ab2932493a8e25bbed47f7668e4c3338152defc01a/django-debreach-2.1.0.tar.gz
BuildArch:	noarch


%description
Extra mitigation against the `BREACH attack <http://breachattack.com/>`_ 
for Django projects. 
django-debreach provides additional protection to Django's built in CSRF
token masking by randomising the content length of each response. This is 
achieved by adding a random string of between 12 and 25 characters as a 
comment to the end of the HTML content. Note that this will only be applied to 
responses with a content type of ``text/html``.
When combined with the built-in mitigations in Django and rate limiting 
(either in your web-server, or by using something like 
`django-ratelimit <http://django-ratelimit.readthedocs.org/>`_), the 
techniques here should provide a fairly comprehensive protection against the 
BREACH attack.

%package -n python3-django-debreach
Summary:	Adds middleware to give some added protection against the BREACH attack in Django.
Provides:	python-django-debreach
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-django-debreach
Extra mitigation against the `BREACH attack <http://breachattack.com/>`_ 
for Django projects. 
django-debreach provides additional protection to Django's built in CSRF
token masking by randomising the content length of each response. This is 
achieved by adding a random string of between 12 and 25 characters as a 
comment to the end of the HTML content. Note that this will only be applied to 
responses with a content type of ``text/html``.
When combined with the built-in mitigations in Django and rate limiting 
(either in your web-server, or by using something like 
`django-ratelimit <http://django-ratelimit.readthedocs.org/>`_), the 
techniques here should provide a fairly comprehensive protection against the 
BREACH attack.

%package help
Summary:	Development documents and examples for django-debreach
Provides:	python3-django-debreach-doc
%description help
Extra mitigation against the `BREACH attack <http://breachattack.com/>`_ 
for Django projects. 
django-debreach provides additional protection to Django's built in CSRF
token masking by randomising the content length of each response. This is 
achieved by adding a random string of between 12 and 25 characters as a 
comment to the end of the HTML content. Note that this will only be applied to 
responses with a content type of ``text/html``.
When combined with the built-in mitigations in Django and rate limiting 
(either in your web-server, or by using something like 
`django-ratelimit <http://django-ratelimit.readthedocs.org/>`_), the 
techniques here should provide a fairly comprehensive protection against the 
BREACH attack.

%prep
%autosetup -n django-debreach-2.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-django-debreach -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.0-1
- Package Spec generated