%global _empty_manifest_terminate_build 0
Name: python-flann
Version: 1.6.13
Release: 1
Summary: flann is the python 3.6 bindings for FLANN - Fast Library for Approximate Nearest Neighbors.
License: BSD
URL: https://github.com/pypa/flann
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/67/ba/04b7e7d0c84a7c9931cfaee088a2c70b8327538f76eae8b8d7f81f9748db/flann-1.6.13.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-check-manifest
Requires: python3-coverage
%description
1. Introduction
~~~~~~~~~~~~~~~
pyflann is the python bindings for `FLANN - Fast Library for Approximate
Nearest Neighbors `__.
2. Install
~~~~~~~~~~
For python2
^^^^^^^^^^^
This package uses distutils, which is the default way of installing
python modules. To install in your home directory, securely run the
following:
git clone https://github.com/primetang/pyflann.git
cd pyflann
[sudo] python setup.py install
Or directly through ``pip`` to install it:
[sudo] pip install pyflann
For python3
^^^^^^^^^^^
Please refer to `this
issuse `__ to modify the
code.
3. Usage
~~~~~~~~
Use it just like the following code:
from pyflann import *
import numpy as np
dataset = np.array(
[[1., 1, 1, 2, 3],
[10, 10, 10, 3, 2],
[100, 100, 2, 30, 1]
])
testset = np.array(
[[1., 1, 1, 1, 1],
[90, 90, 10, 10, 1]
])
flann = FLANN()
result, dists = flann.nn(
dataset, testset, 2, algorithm="kmeans", branching=32, iterations=7, checks=16)
print result
print dists
dataset = np.random.rand(10000, 128)
testset = np.random.rand(1000, 128)
flann = FLANN()
result, dists = flann.nn(
dataset, testset, 5, algorithm="kmeans", branching=32, iterations=7, checks=16)
print result
print dists
%package -n python3-flann
Summary: flann is the python 3.6 bindings for FLANN - Fast Library for Approximate Nearest Neighbors.
Provides: python-flann
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-flann
1. Introduction
~~~~~~~~~~~~~~~
pyflann is the python bindings for `FLANN - Fast Library for Approximate
Nearest Neighbors `__.
2. Install
~~~~~~~~~~
For python2
^^^^^^^^^^^
This package uses distutils, which is the default way of installing
python modules. To install in your home directory, securely run the
following:
git clone https://github.com/primetang/pyflann.git
cd pyflann
[sudo] python setup.py install
Or directly through ``pip`` to install it:
[sudo] pip install pyflann
For python3
^^^^^^^^^^^
Please refer to `this
issuse `__ to modify the
code.
3. Usage
~~~~~~~~
Use it just like the following code:
from pyflann import *
import numpy as np
dataset = np.array(
[[1., 1, 1, 2, 3],
[10, 10, 10, 3, 2],
[100, 100, 2, 30, 1]
])
testset = np.array(
[[1., 1, 1, 1, 1],
[90, 90, 10, 10, 1]
])
flann = FLANN()
result, dists = flann.nn(
dataset, testset, 2, algorithm="kmeans", branching=32, iterations=7, checks=16)
print result
print dists
dataset = np.random.rand(10000, 128)
testset = np.random.rand(1000, 128)
flann = FLANN()
result, dists = flann.nn(
dataset, testset, 5, algorithm="kmeans", branching=32, iterations=7, checks=16)
print result
print dists
%package help
Summary: Development documents and examples for flann
Provides: python3-flann-doc
%description help
1. Introduction
~~~~~~~~~~~~~~~
pyflann is the python bindings for `FLANN - Fast Library for Approximate
Nearest Neighbors `__.
2. Install
~~~~~~~~~~
For python2
^^^^^^^^^^^
This package uses distutils, which is the default way of installing
python modules. To install in your home directory, securely run the
following:
git clone https://github.com/primetang/pyflann.git
cd pyflann
[sudo] python setup.py install
Or directly through ``pip`` to install it:
[sudo] pip install pyflann
For python3
^^^^^^^^^^^
Please refer to `this
issuse `__ to modify the
code.
3. Usage
~~~~~~~~
Use it just like the following code:
from pyflann import *
import numpy as np
dataset = np.array(
[[1., 1, 1, 2, 3],
[10, 10, 10, 3, 2],
[100, 100, 2, 30, 1]
])
testset = np.array(
[[1., 1, 1, 1, 1],
[90, 90, 10, 10, 1]
])
flann = FLANN()
result, dists = flann.nn(
dataset, testset, 2, algorithm="kmeans", branching=32, iterations=7, checks=16)
print result
print dists
dataset = np.random.rand(10000, 128)
testset = np.random.rand(1000, 128)
flann = FLANN()
result, dists = flann.nn(
dataset, testset, 5, algorithm="kmeans", branching=32, iterations=7, checks=16)
print result
print dists
%prep
%autosetup -n flann-1.6.13
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-flann -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 1.6.13-1
- Package Spec generated