%global _empty_manifest_terminate_build 0
Name:		python-inema
Version:	0.8.7
Release:	1
Summary:	A Python interface to the Deutsche Post Internetmarke and Warenpost International Online Franking
License:	AGPLv3
URL:		https://git.sysmocom.de/odoo/python-inema/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/fa/00/63e8285e9c2a4da460e6476e858de2f1f561d22d16426f614865a2eca953/inema-0.8.7.tar.gz
BuildArch:	noarch


%description
This is a python module for interfacing the "Internetmarke" API provided
by the German postal company "Deutsche Post".  It implements V3 of this
API.  It also implements the new (2020) "Warenpost International API".
The Internetmarke API allows you to buy online franking for national and
international postal products like post cards and letters of all weight
classes and service classes (normal, registered, ...).

%package -n python3-inema
Summary:	A Python interface to the Deutsche Post Internetmarke and Warenpost International Online Franking
Provides:	python-inema
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-inema
This is a python module for interfacing the "Internetmarke" API provided
by the German postal company "Deutsche Post".  It implements V3 of this
API.  It also implements the new (2020) "Warenpost International API".
The Internetmarke API allows you to buy online franking for national and
international postal products like post cards and letters of all weight
classes and service classes (normal, registered, ...).

%package help
Summary:	Development documents and examples for inema
Provides:	python3-inema-doc
%description help
This is a python module for interfacing the "Internetmarke" API provided
by the German postal company "Deutsche Post".  It implements V3 of this
API.  It also implements the new (2020) "Warenpost International API".
The Internetmarke API allows you to buy online franking for national and
international postal products like post cards and letters of all weight
classes and service classes (normal, registered, ...).

%prep
%autosetup -n inema-0.8.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-inema -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.7-1
- Package Spec generated