%global _empty_manifest_terminate_build 0
Name:		python-mutagen
Version:	1.46.0
Release:	1
Summary:	read and write audio tags for many formats
License:	GPL-2.0-or-later
URL:		https://github.com/quodlibet/mutagen
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b1/54/d1760a363d0fe345528e37782f6c18123b0e99e8ea755022fd51f1ecd0f9/mutagen-1.46.0.tar.gz
BuildArch:	noarch


%description
.. image:: https://raw.githubusercontent.com/quodlibet/mutagen/master/docs/images/logo.svg
   :align: center
   :width: 400px

|

Mutagen is a Python module to handle audio metadata. It supports ASF, FLAC,
MP4, Monkey's Audio, MP3, Musepack, Ogg Opus, Ogg FLAC, Ogg Speex, Ogg Theora,
Ogg Vorbis, True Audio, WavPack, OptimFROG, and AIFF audio files. All
versions of ID3v2 are supported, and all standard ID3v2.4 frames are parsed.
It can read Xing headers to accurately calculate the bitrate and length of
MP3s. ID3 and APEv2 tags can be edited regardless of audio format. It can also
manipulate Ogg streams on an individual packet/page level.

Mutagen works with Python 3.7+ (CPython and PyPy) on Linux, Windows and macOS,
and has no dependencies outside the Python standard library. Mutagen is licensed
under `the GPL version 2 or
later <https://spdx.org/licenses/GPL-2.0-or-later.html>`__.

For more information visit https://mutagen.readthedocs.org

.. image:: https://codecov.io/gh/quodlibet/mutagen/branch/master/graph/badge.svg
  :target: https://codecov.io/gh/quodlibet/mutagen




%package -n python3-mutagen
Summary:	read and write audio tags for many formats
Provides:	python-mutagen
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-mutagen
.. image:: https://raw.githubusercontent.com/quodlibet/mutagen/master/docs/images/logo.svg
   :align: center
   :width: 400px

|

Mutagen is a Python module to handle audio metadata. It supports ASF, FLAC,
MP4, Monkey's Audio, MP3, Musepack, Ogg Opus, Ogg FLAC, Ogg Speex, Ogg Theora,
Ogg Vorbis, True Audio, WavPack, OptimFROG, and AIFF audio files. All
versions of ID3v2 are supported, and all standard ID3v2.4 frames are parsed.
It can read Xing headers to accurately calculate the bitrate and length of
MP3s. ID3 and APEv2 tags can be edited regardless of audio format. It can also
manipulate Ogg streams on an individual packet/page level.

Mutagen works with Python 3.7+ (CPython and PyPy) on Linux, Windows and macOS,
and has no dependencies outside the Python standard library. Mutagen is licensed
under `the GPL version 2 or
later <https://spdx.org/licenses/GPL-2.0-or-later.html>`__.

For more information visit https://mutagen.readthedocs.org

.. image:: https://codecov.io/gh/quodlibet/mutagen/branch/master/graph/badge.svg
  :target: https://codecov.io/gh/quodlibet/mutagen




%package help
Summary:	Development documents and examples for mutagen
Provides:	python3-mutagen-doc
%description help
.. image:: https://raw.githubusercontent.com/quodlibet/mutagen/master/docs/images/logo.svg
   :align: center
   :width: 400px

|

Mutagen is a Python module to handle audio metadata. It supports ASF, FLAC,
MP4, Monkey's Audio, MP3, Musepack, Ogg Opus, Ogg FLAC, Ogg Speex, Ogg Theora,
Ogg Vorbis, True Audio, WavPack, OptimFROG, and AIFF audio files. All
versions of ID3v2 are supported, and all standard ID3v2.4 frames are parsed.
It can read Xing headers to accurately calculate the bitrate and length of
MP3s. ID3 and APEv2 tags can be edited regardless of audio format. It can also
manipulate Ogg streams on an individual packet/page level.

Mutagen works with Python 3.7+ (CPython and PyPy) on Linux, Windows and macOS,
and has no dependencies outside the Python standard library. Mutagen is licensed
under `the GPL version 2 or
later <https://spdx.org/licenses/GPL-2.0-or-later.html>`__.

For more information visit https://mutagen.readthedocs.org

.. image:: https://codecov.io/gh/quodlibet/mutagen/branch/master/graph/badge.svg
  :target: https://codecov.io/gh/quodlibet/mutagen




%prep
%autosetup -n mutagen-1.46.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-mutagen -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 1.46.0-1
- Package Spec generated