%global _empty_manifest_terminate_build 0
Name: python-pytest-sanic
Version: 1.9.1
Release: 1
Summary: a pytest plugin for Sanic
License: MIT
URL: https://github.com/yunstanford/pytest-sanic
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/72/ac/4ee956ff836a8491d34c1cf198b91f859baee0374c9ae85767bb3debc59d/pytest-sanic-1.9.1.tar.gz
BuildArch: noarch
Requires: python3-pytest
Requires: python3-async_generator
Requires: python3-httpx
Requires: python3-websockets
%description
* - Build
- | |travis|
* - Docs
- |docs|
* - Package
- | |version| |wheel| |supported-versions| |supported-implementations|
A pytest plugin for `Sanic `_. It helps you to test your code asynchronously.
This plugin provides:
* very easy testing with async coroutines
* common and useful fixtures
* asynchronous fixture support
* test_client/sanic_client for Sanic application
* test_server for Sanic application
You can find out more here:
http://pytest-sanic.readthedocs.io/en/latest/
Releases and change logs can be found here:
%package -n python3-pytest-sanic
Summary: a pytest plugin for Sanic
Provides: python-pytest-sanic
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pytest-sanic
* - Build
- | |travis|
* - Docs
- |docs|
* - Package
- | |version| |wheel| |supported-versions| |supported-implementations|
A pytest plugin for `Sanic `_. It helps you to test your code asynchronously.
This plugin provides:
* very easy testing with async coroutines
* common and useful fixtures
* asynchronous fixture support
* test_client/sanic_client for Sanic application
* test_server for Sanic application
You can find out more here:
http://pytest-sanic.readthedocs.io/en/latest/
Releases and change logs can be found here:
%package help
Summary: Development documents and examples for pytest-sanic
Provides: python3-pytest-sanic-doc
%description help
* - Build
- | |travis|
* - Docs
- |docs|
* - Package
- | |version| |wheel| |supported-versions| |supported-implementations|
A pytest plugin for `Sanic `_. It helps you to test your code asynchronously.
This plugin provides:
* very easy testing with async coroutines
* common and useful fixtures
* asynchronous fixture support
* test_client/sanic_client for Sanic application
* test_server for Sanic application
You can find out more here:
http://pytest-sanic.readthedocs.io/en/latest/
Releases and change logs can be found here:
%prep
%autosetup -n pytest-sanic-1.9.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pytest-sanic -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 1.9.1-1
- Package Spec generated