%global _empty_manifest_terminate_build 0
Name: python-xmlsec
Version: 1.3.13
Release: 1
Summary: Python bindings for the XML Security Library
License: MIT
URL: https://github.com/mehcode/python-xmlsec
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/37/9f/342d4562eac99178d0d515c780285e107c6828cefad37d02f05b7b7d8751/xmlsec-1.3.13.tar.gz
Requires: python3-lxml
%description
Python bindings for the `XML Security Library `_.
Documentation
*************
A documentation for ``xmlsec`` can be found at `xmlsec.readthedocs.io `_.
Usage
*****
Check the `examples `_ section in the documentation to see various examples of signing and verifying using the library.
Requirements
************
- ``libxml2 >= 2.9.1``
- ``libxmlsec1 >= 1.2.18``
Install
*******
``xmlsec`` is available on PyPI:
pip install xmlsec
Depending on your OS, you may need to install the required native
libraries first:
Linux (Debian)
^^^^^^^^^^^^^^
apt-get install pkg-config libxml2-dev libxmlsec1-dev libxmlsec1-openssl
Note: There is no required version of LibXML2 for Ubuntu Precise,
so you need to download and install it manually.
wget http://xmlsoft.org/sources/libxml2-2.9.1.tar.gz
tar -xvf libxml2-2.9.1.tar.gz
cd libxml2-2.9.1
./configure && make && make install
Linux (CentOS)
^^^^^^^^^^^^^^
yum install libxml2-devel xmlsec1-devel xmlsec1-openssl-devel libtool-ltdl-devel
Linux (Fedora)
^^^^^^^^^^^^^^
dnf install libxml2-devel xmlsec1-devel xmlsec1-openssl-devel libtool-ltdl-devel
Mac
^^^
brew install libxml2 libxmlsec1 pkg-config
Alpine
^^^^^^
apk add build-base libressl libffi-dev libressl-dev libxslt-dev libxml2-dev xmlsec-dev xmlsec
Troubleshooting
***************
Mac
^^^
If you get any fatal errors about missing ``.h`` files, update your
``C_INCLUDE_PATH`` environment variable to include the appropriate
files from the ``libxml2`` and ``libxmlsec1`` libraries.
Windows
^^^^^^^
Starting with 1.3.7, prebuilt wheels are available for Windows,
so running ``pip install xmlsec`` should suffice. If you want
to build from source:
#. Configure build environment, see `wiki.python.org `_ for more details.
#. Install from source dist:
pip install xmlsec --no-binary=xmlsec
Building from source
********************
#. Clone the ``xmlsec`` source code repository to your local computer.
git clone https://github.com/mehcode/python-xmlsec.git
#. Change into the ``python-xmlsec`` root directory.
cd /path/to/xmlsec
#. Install the project and all its dependencies using ``pip``.
pip install .
Contributing
************
Setting up your environment
^^^^^^^^^^^^^^^^^^^^^^^^^^^
#. Follow steps 1 and 2 of the `manual installation instructions <#building-from-source>`_.
#. Initialize a virtual environment to develop in.
This is done so as to ensure every contributor is working with
close-to-identicial versions of packages.
mkvirtualenv xmlsec
The ``mkvirtualenv`` command is available from ``virtualenvwrapper`` package which can be installed by following `link `_.
#. Activate the created virtual environment:
workon xmlsec
#. Install ``xmlsec`` in development mode with testing enabled.
This will download all dependencies required for running the unit tests.
pip install -r requirements-test.txt
pip install -e "."
Running the test suite
^^^^^^^^^^^^^^^^^^^^^^
#. `Set up your environment <#setting-up-your-environment>`_.
#. Run the unit tests.
pytest tests
#. Tests configuration
Env variable ``PYXMLSEC_TEST_ITERATIONS`` specifies number of
test iterations to detect memory leaks.
Reporting an issue
^^^^^^^^^^^^^^^^^^
Please attach the output of following information:
* version of ``xmlsec``
* version of ``libxmlsec1``
* version of ``libxml2``
* output from the command
pkg-config --cflags xmlsec1
License
*******
Unless otherwise noted, all files contained within this project are licensed under the MIT opensource license.
See the included ``LICENSE`` file or visit `opensource.org `_ for more information.
%package -n python3-xmlsec
Summary: Python bindings for the XML Security Library
Provides: python-xmlsec
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-xmlsec
Python bindings for the `XML Security Library `_.
Documentation
*************
A documentation for ``xmlsec`` can be found at `xmlsec.readthedocs.io `_.
Usage
*****
Check the `examples `_ section in the documentation to see various examples of signing and verifying using the library.
Requirements
************
- ``libxml2 >= 2.9.1``
- ``libxmlsec1 >= 1.2.18``
Install
*******
``xmlsec`` is available on PyPI:
pip install xmlsec
Depending on your OS, you may need to install the required native
libraries first:
Linux (Debian)
^^^^^^^^^^^^^^
apt-get install pkg-config libxml2-dev libxmlsec1-dev libxmlsec1-openssl
Note: There is no required version of LibXML2 for Ubuntu Precise,
so you need to download and install it manually.
wget http://xmlsoft.org/sources/libxml2-2.9.1.tar.gz
tar -xvf libxml2-2.9.1.tar.gz
cd libxml2-2.9.1
./configure && make && make install
Linux (CentOS)
^^^^^^^^^^^^^^
yum install libxml2-devel xmlsec1-devel xmlsec1-openssl-devel libtool-ltdl-devel
Linux (Fedora)
^^^^^^^^^^^^^^
dnf install libxml2-devel xmlsec1-devel xmlsec1-openssl-devel libtool-ltdl-devel
Mac
^^^
brew install libxml2 libxmlsec1 pkg-config
Alpine
^^^^^^
apk add build-base libressl libffi-dev libressl-dev libxslt-dev libxml2-dev xmlsec-dev xmlsec
Troubleshooting
***************
Mac
^^^
If you get any fatal errors about missing ``.h`` files, update your
``C_INCLUDE_PATH`` environment variable to include the appropriate
files from the ``libxml2`` and ``libxmlsec1`` libraries.
Windows
^^^^^^^
Starting with 1.3.7, prebuilt wheels are available for Windows,
so running ``pip install xmlsec`` should suffice. If you want
to build from source:
#. Configure build environment, see `wiki.python.org `_ for more details.
#. Install from source dist:
pip install xmlsec --no-binary=xmlsec
Building from source
********************
#. Clone the ``xmlsec`` source code repository to your local computer.
git clone https://github.com/mehcode/python-xmlsec.git
#. Change into the ``python-xmlsec`` root directory.
cd /path/to/xmlsec
#. Install the project and all its dependencies using ``pip``.
pip install .
Contributing
************
Setting up your environment
^^^^^^^^^^^^^^^^^^^^^^^^^^^
#. Follow steps 1 and 2 of the `manual installation instructions <#building-from-source>`_.
#. Initialize a virtual environment to develop in.
This is done so as to ensure every contributor is working with
close-to-identicial versions of packages.
mkvirtualenv xmlsec
The ``mkvirtualenv`` command is available from ``virtualenvwrapper`` package which can be installed by following `link `_.
#. Activate the created virtual environment:
workon xmlsec
#. Install ``xmlsec`` in development mode with testing enabled.
This will download all dependencies required for running the unit tests.
pip install -r requirements-test.txt
pip install -e "."
Running the test suite
^^^^^^^^^^^^^^^^^^^^^^
#. `Set up your environment <#setting-up-your-environment>`_.
#. Run the unit tests.
pytest tests
#. Tests configuration
Env variable ``PYXMLSEC_TEST_ITERATIONS`` specifies number of
test iterations to detect memory leaks.
Reporting an issue
^^^^^^^^^^^^^^^^^^
Please attach the output of following information:
* version of ``xmlsec``
* version of ``libxmlsec1``
* version of ``libxml2``
* output from the command
pkg-config --cflags xmlsec1
License
*******
Unless otherwise noted, all files contained within this project are licensed under the MIT opensource license.
See the included ``LICENSE`` file or visit `opensource.org `_ for more information.
%package help
Summary: Development documents and examples for xmlsec
Provides: python3-xmlsec-doc
%description help
Python bindings for the `XML Security Library `_.
Documentation
*************
A documentation for ``xmlsec`` can be found at `xmlsec.readthedocs.io `_.
Usage
*****
Check the `examples `_ section in the documentation to see various examples of signing and verifying using the library.
Requirements
************
- ``libxml2 >= 2.9.1``
- ``libxmlsec1 >= 1.2.18``
Install
*******
``xmlsec`` is available on PyPI:
pip install xmlsec
Depending on your OS, you may need to install the required native
libraries first:
Linux (Debian)
^^^^^^^^^^^^^^
apt-get install pkg-config libxml2-dev libxmlsec1-dev libxmlsec1-openssl
Note: There is no required version of LibXML2 for Ubuntu Precise,
so you need to download and install it manually.
wget http://xmlsoft.org/sources/libxml2-2.9.1.tar.gz
tar -xvf libxml2-2.9.1.tar.gz
cd libxml2-2.9.1
./configure && make && make install
Linux (CentOS)
^^^^^^^^^^^^^^
yum install libxml2-devel xmlsec1-devel xmlsec1-openssl-devel libtool-ltdl-devel
Linux (Fedora)
^^^^^^^^^^^^^^
dnf install libxml2-devel xmlsec1-devel xmlsec1-openssl-devel libtool-ltdl-devel
Mac
^^^
brew install libxml2 libxmlsec1 pkg-config
Alpine
^^^^^^
apk add build-base libressl libffi-dev libressl-dev libxslt-dev libxml2-dev xmlsec-dev xmlsec
Troubleshooting
***************
Mac
^^^
If you get any fatal errors about missing ``.h`` files, update your
``C_INCLUDE_PATH`` environment variable to include the appropriate
files from the ``libxml2`` and ``libxmlsec1`` libraries.
Windows
^^^^^^^
Starting with 1.3.7, prebuilt wheels are available for Windows,
so running ``pip install xmlsec`` should suffice. If you want
to build from source:
#. Configure build environment, see `wiki.python.org `_ for more details.
#. Install from source dist:
pip install xmlsec --no-binary=xmlsec
Building from source
********************
#. Clone the ``xmlsec`` source code repository to your local computer.
git clone https://github.com/mehcode/python-xmlsec.git
#. Change into the ``python-xmlsec`` root directory.
cd /path/to/xmlsec
#. Install the project and all its dependencies using ``pip``.
pip install .
Contributing
************
Setting up your environment
^^^^^^^^^^^^^^^^^^^^^^^^^^^
#. Follow steps 1 and 2 of the `manual installation instructions <#building-from-source>`_.
#. Initialize a virtual environment to develop in.
This is done so as to ensure every contributor is working with
close-to-identicial versions of packages.
mkvirtualenv xmlsec
The ``mkvirtualenv`` command is available from ``virtualenvwrapper`` package which can be installed by following `link `_.
#. Activate the created virtual environment:
workon xmlsec
#. Install ``xmlsec`` in development mode with testing enabled.
This will download all dependencies required for running the unit tests.
pip install -r requirements-test.txt
pip install -e "."
Running the test suite
^^^^^^^^^^^^^^^^^^^^^^
#. `Set up your environment <#setting-up-your-environment>`_.
#. Run the unit tests.
pytest tests
#. Tests configuration
Env variable ``PYXMLSEC_TEST_ITERATIONS`` specifies number of
test iterations to detect memory leaks.
Reporting an issue
^^^^^^^^^^^^^^^^^^
Please attach the output of following information:
* version of ``xmlsec``
* version of ``libxmlsec1``
* version of ``libxml2``
* output from the command
pkg-config --cflags xmlsec1
License
*******
Unless otherwise noted, all files contained within this project are licensed under the MIT opensource license.
See the included ``LICENSE`` file or visit `opensource.org `_ for more information.
%prep
%autosetup -n xmlsec-1.3.13
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-xmlsec -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 1.3.13-1
- Package Spec generated