%global _empty_manifest_terminate_build 0
Name:		python-SQLAlchemy-JSONField
Version:	1.0.1.post0
Release:	1
Summary:	SQLALchemy JSONField implementation for storing dicts at SQL
License:	Apache License, Version 2.0
URL:		https://pypi.org/project/SQLAlchemy-JSONField/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/2a/97/367a46033f71ee057b789f76c0801a7d4537ea4401e702875b578a17989d/SQLAlchemy-JSONField-1.0.1.post0.tar.gz
BuildArch:	noarch

Requires:	python3-sqlalchemy

%description
SQLALchemy JSONField implementation for storing dicts at SQL independently from JSON type support.

%package -n python3-SQLAlchemy-JSONField
Summary:	SQLALchemy JSONField implementation for storing dicts at SQL
Provides:	python-SQLAlchemy-JSONField
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-SQLAlchemy-JSONField
SQLALchemy JSONField implementation for storing dicts at SQL independently from JSON type support.

%package help
Summary:	Development documents and examples for SQLAlchemy-JSONField
Provides:	python3-SQLAlchemy-JSONField-doc
%description help
SQLALchemy JSONField implementation for storing dicts at SQL independently from JSON type support.

%prep
%autosetup -n SQLAlchemy-JSONField-1.0.1.post0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-SQLAlchemy-JSONField -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.1.post0-1
- Package Spec generated