%global _empty_manifest_terminate_build 0
Name: python-ccxt
Version: 3.0.74
Release: 1
Summary: A JavaScript / Python / PHP cryptocurrency trading library with support for 130+ exchanges
License: MIT
URL: https://ccxt.com
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/df/8f/daf825966dea3027fe9e03dc7db81646b8e57cae080f87d741cda8445d55/ccxt-3.0.74.tar.gz
BuildArch: noarch
Requires: python3-setuptools
Requires: python3-certifi
Requires: python3-requests
Requires: python3-cryptography
Requires: python3-aiohttp
Requires: python3-aiodns
Requires: python3-yarl
Requires: python3-flake8
%description
## Install
The easiest way to install the CCXT library is to use a package manager:
- [ccxt in **NPM**](https://www.npmjs.com/package/ccxt) (JavaScript / Node v7.6+)
- [ccxt in **PyPI**](https://pypi.python.org/pypi/ccxt) (Python 3.5.3+)
- [ccxt in **Packagist/Composer**](https://packagist.org/packages/ccxt/ccxt) (PHP 7.0+)
This library is shipped as an all-in-one module implementation with minimalistic dependencies and requirements:
- [js/](https://github.com/ccxt/ccxt/blob/master/js/) in JavaScript
- [python/](https://github.com/ccxt/ccxt/blob/master/python/) in Python (generated from JS)
- [php/](https://github.com/ccxt/ccxt/blob/master/php/) in PHP (generated from JS)
You can also clone it into your project directory from [ccxt GitHub repository](https://github.com/ccxt/ccxt):
```shell
git clone https://github.com/ccxt/ccxt.git # including 1GB of commit history
# or
git clone https://github.com/ccxt/ccxt.git --depth 1 # avoid downloading 1GB of commit history
```
### JavaScript (NPM)
JavaScript version of CCXT works in both Node and web browsers. Requires ES6 and `async/await` syntax support (Node 7.6.0+). When compiling with Webpack and Babel, make sure it is [not excluded](https://github.com/ccxt/ccxt/issues/225#issuecomment-331905178) in your `babel-loader` config.
[ccxt in **NPM**](https://www.npmjs.com/package/ccxt)
```shell
npm install ccxt
```
```JavaScript
//cjs
var ccxt = require ('ccxt')
console.log (ccxt.exchanges) // print all available exchanges
```
```Javascript
//esm
import {version, exchanges} from 'ccxt';
console.log(version, Object.keys(exchanges));
```
### JavaScript (for use with the `
```
Creates a global `ccxt` object:
```JavaScript
console.log (ccxt.exchanges) // print all available exchanges
```
### Python
[ccxt in **PyPI**](https://pypi.python.org/pypi/ccxt)
```shell
pip install ccxt
```
```Python
import ccxt
print(ccxt.exchanges) # print a list of all available exchange classes
```
The library supports concurrent asynchronous mode with asyncio and async/await in Python 3.5.3+
```Python
import ccxt.async_support as ccxt # link against the asynchronous version of ccxt
```
### PHP
[ccxt in PHP with **Packagist/Composer**](https://packagist.org/packages/ccxt/ccxt) (PHP 7.0+)
It requires common PHP modules:
- cURL
- mbstring (using UTF-8 is highly recommended)
- PCRE
- iconv
- gmp (this is a built-in extension as of PHP 7.2+)
```PHP
include "ccxt.php";
var_dump (\ccxt\Exchange::$exchanges); // print a list of all available exchange classes
```
The library supports concurrent asynchronous mode using tools from [RecoilPHP](https://github.com/recoilphp/recoil) and [ReactPHP](https://reactphp.org/) in PHP 7.1+. Read the [Manual](https://docs.ccxt.com/#/README) for more details.
### Docker
You can get CCXT installed in a container along with all the supported languages and dependencies. This may be useful if you want to contribute to CCXT (e.g. run the build scripts and tests — please see the [Contributing](https://github.com/ccxt/ccxt/blob/master/CONTRIBUTING.md) document for the details on that).
Using `docker-compose` (in the cloned CCXT repository):
```shell
docker-compose run --rm ccxt
```
%package -n python3-ccxt
Summary: A JavaScript / Python / PHP cryptocurrency trading library with support for 130+ exchanges
Provides: python-ccxt
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ccxt
## Install
The easiest way to install the CCXT library is to use a package manager:
- [ccxt in **NPM**](https://www.npmjs.com/package/ccxt) (JavaScript / Node v7.6+)
- [ccxt in **PyPI**](https://pypi.python.org/pypi/ccxt) (Python 3.5.3+)
- [ccxt in **Packagist/Composer**](https://packagist.org/packages/ccxt/ccxt) (PHP 7.0+)
This library is shipped as an all-in-one module implementation with minimalistic dependencies and requirements:
- [js/](https://github.com/ccxt/ccxt/blob/master/js/) in JavaScript
- [python/](https://github.com/ccxt/ccxt/blob/master/python/) in Python (generated from JS)
- [php/](https://github.com/ccxt/ccxt/blob/master/php/) in PHP (generated from JS)
You can also clone it into your project directory from [ccxt GitHub repository](https://github.com/ccxt/ccxt):
```shell
git clone https://github.com/ccxt/ccxt.git # including 1GB of commit history
# or
git clone https://github.com/ccxt/ccxt.git --depth 1 # avoid downloading 1GB of commit history
```
### JavaScript (NPM)
JavaScript version of CCXT works in both Node and web browsers. Requires ES6 and `async/await` syntax support (Node 7.6.0+). When compiling with Webpack and Babel, make sure it is [not excluded](https://github.com/ccxt/ccxt/issues/225#issuecomment-331905178) in your `babel-loader` config.
[ccxt in **NPM**](https://www.npmjs.com/package/ccxt)
```shell
npm install ccxt
```
```JavaScript
//cjs
var ccxt = require ('ccxt')
console.log (ccxt.exchanges) // print all available exchanges
```
```Javascript
//esm
import {version, exchanges} from 'ccxt';
console.log(version, Object.keys(exchanges));
```
### JavaScript (for use with the `
```
Creates a global `ccxt` object:
```JavaScript
console.log (ccxt.exchanges) // print all available exchanges
```
### Python
[ccxt in **PyPI**](https://pypi.python.org/pypi/ccxt)
```shell
pip install ccxt
```
```Python
import ccxt
print(ccxt.exchanges) # print a list of all available exchange classes
```
The library supports concurrent asynchronous mode with asyncio and async/await in Python 3.5.3+
```Python
import ccxt.async_support as ccxt # link against the asynchronous version of ccxt
```
### PHP
[ccxt in PHP with **Packagist/Composer**](https://packagist.org/packages/ccxt/ccxt) (PHP 7.0+)
It requires common PHP modules:
- cURL
- mbstring (using UTF-8 is highly recommended)
- PCRE
- iconv
- gmp (this is a built-in extension as of PHP 7.2+)
```PHP
include "ccxt.php";
var_dump (\ccxt\Exchange::$exchanges); // print a list of all available exchange classes
```
The library supports concurrent asynchronous mode using tools from [RecoilPHP](https://github.com/recoilphp/recoil) and [ReactPHP](https://reactphp.org/) in PHP 7.1+. Read the [Manual](https://docs.ccxt.com/#/README) for more details.
### Docker
You can get CCXT installed in a container along with all the supported languages and dependencies. This may be useful if you want to contribute to CCXT (e.g. run the build scripts and tests — please see the [Contributing](https://github.com/ccxt/ccxt/blob/master/CONTRIBUTING.md) document for the details on that).
Using `docker-compose` (in the cloned CCXT repository):
```shell
docker-compose run --rm ccxt
```
%package help
Summary: Development documents and examples for ccxt
Provides: python3-ccxt-doc
%description help
## Install
The easiest way to install the CCXT library is to use a package manager:
- [ccxt in **NPM**](https://www.npmjs.com/package/ccxt) (JavaScript / Node v7.6+)
- [ccxt in **PyPI**](https://pypi.python.org/pypi/ccxt) (Python 3.5.3+)
- [ccxt in **Packagist/Composer**](https://packagist.org/packages/ccxt/ccxt) (PHP 7.0+)
This library is shipped as an all-in-one module implementation with minimalistic dependencies and requirements:
- [js/](https://github.com/ccxt/ccxt/blob/master/js/) in JavaScript
- [python/](https://github.com/ccxt/ccxt/blob/master/python/) in Python (generated from JS)
- [php/](https://github.com/ccxt/ccxt/blob/master/php/) in PHP (generated from JS)
You can also clone it into your project directory from [ccxt GitHub repository](https://github.com/ccxt/ccxt):
```shell
git clone https://github.com/ccxt/ccxt.git # including 1GB of commit history
# or
git clone https://github.com/ccxt/ccxt.git --depth 1 # avoid downloading 1GB of commit history
```
### JavaScript (NPM)
JavaScript version of CCXT works in both Node and web browsers. Requires ES6 and `async/await` syntax support (Node 7.6.0+). When compiling with Webpack and Babel, make sure it is [not excluded](https://github.com/ccxt/ccxt/issues/225#issuecomment-331905178) in your `babel-loader` config.
[ccxt in **NPM**](https://www.npmjs.com/package/ccxt)
```shell
npm install ccxt
```
```JavaScript
//cjs
var ccxt = require ('ccxt')
console.log (ccxt.exchanges) // print all available exchanges
```
```Javascript
//esm
import {version, exchanges} from 'ccxt';
console.log(version, Object.keys(exchanges));
```
### JavaScript (for use with the `
```
Creates a global `ccxt` object:
```JavaScript
console.log (ccxt.exchanges) // print all available exchanges
```
### Python
[ccxt in **PyPI**](https://pypi.python.org/pypi/ccxt)
```shell
pip install ccxt
```
```Python
import ccxt
print(ccxt.exchanges) # print a list of all available exchange classes
```
The library supports concurrent asynchronous mode with asyncio and async/await in Python 3.5.3+
```Python
import ccxt.async_support as ccxt # link against the asynchronous version of ccxt
```
### PHP
[ccxt in PHP with **Packagist/Composer**](https://packagist.org/packages/ccxt/ccxt) (PHP 7.0+)
It requires common PHP modules:
- cURL
- mbstring (using UTF-8 is highly recommended)
- PCRE
- iconv
- gmp (this is a built-in extension as of PHP 7.2+)
```PHP
include "ccxt.php";
var_dump (\ccxt\Exchange::$exchanges); // print a list of all available exchange classes
```
The library supports concurrent asynchronous mode using tools from [RecoilPHP](https://github.com/recoilphp/recoil) and [ReactPHP](https://reactphp.org/) in PHP 7.1+. Read the [Manual](https://docs.ccxt.com/#/README) for more details.
### Docker
You can get CCXT installed in a container along with all the supported languages and dependencies. This may be useful if you want to contribute to CCXT (e.g. run the build scripts and tests — please see the [Contributing](https://github.com/ccxt/ccxt/blob/master/CONTRIBUTING.md) document for the details on that).
Using `docker-compose` (in the cloned CCXT repository):
```shell
docker-compose run --rm ccxt
```
%prep
%autosetup -n ccxt-3.0.74
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ccxt -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 3.0.74-1
- Package Spec generated