%global _empty_manifest_terminate_build 0
Name: python-inquirer
Version: 3.1.3
Release: 1
Summary: Collection of common interactive command line user interfaces, based on Inquirer.js
License: MIT
URL: https://github.com/magmax/python-inquirer
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1b/e3/e2998fad3add25dc7dad7decb8dcd92e71888d7e9514c647d0a461a7381c/inquirer-3.1.3.tar.gz
BuildArch: noarch
Requires: python3-blessed
Requires: python3-editor
Requires: python3-readchar
%description
[][pypi status]
[][pypi status]
[][pypi status]
[][license]
[][black]
[][read the docs]
[][tests]
[][codecov]
[][pre-commit]
[pypi status]: https://pypi.org/project/inquirer/
[read the docs]: https://python-inquirer.readthedocs.io/
[tests]: https://github.com/magmax/python-inquirer/actions?workflow=Tests
[codecov]: https://app.codecov.io/gh/magmax/python-inquirer
[pre-commit]: https://github.com/pre-commit/pre-commit
[black]: https://github.com/psf/black
# python-inquirer
Collection of common interactive command line user interfaces, based on [Inquirer.js].
## Goal and Philosophy
Born as a [Inquirer.js] clone, it shares part of the goals and philosophy.
So, **Inquirer** should ease the process of asking end user **questions**, **parsing**, **validating** answers, managing **hierarchical prompts** and providing **error feedback**.
You can [download the python-inquirer code from GitHub] or [download the wheel from Pypi].
### Platforms support
Python-inquirer supports mainly UNIX-based platforms (eq. Mac OS, Linux, etc.). Windows has experimental support, please let us know if there are any problems!
## Installation
```sh
pip install inquirer
```
## Documentation
Documentation has been moved to [magmax.org/python-inquirer](https://magmax.org/python-inquirer/).
But here you have a couple of usage examples:
### Text
```python
import re
import inquirer
questions = [
inquirer.Text('name', message="What's your name"),
inquirer.Text('surname', message="What's your surname"),
inquirer.Text('phone', message="What's your phone number",
validate=lambda _, x: re.match('\+?\d[\d ]+\d', x),
)
]
answers = inquirer.prompt(questions)
```
### Editor
Like a Text question, but used for larger answers. It opens external text editor which is used to collect the answer.
The environment variables $VISUAL and $EDITOR, can be used to specify which editor should be used. If not present inquirer fallbacks to `vim -> emacs -> nano` in this order based on availability in the system.
External editor handling is done using great library [python-editor](https://github.com/fmoo/python-editor).
Example:
```python
import inquirer
questions = [
inquirer.Editor('long_text', message="Provide long text")
]
answers = inquirer.prompt(questions)
```
### List
Shows a list of choices, and allows the selection of one of them.
Example:
```python
import inquirer
questions = [
inquirer.List('size',
message="What size do you need?",
choices=['Jumbo', 'Large', 'Standard', 'Medium', 'Small', 'Micro'],
),
]
answers = inquirer.prompt(questions)
```
List questions can take one extra argument `carousel=False`. If set to true, the answers will rotate (back to first when pressing down on last choice, and down to last choice when pressing up on first choice)
### Checkbox
Shows a list of choices, with multiple selection.
Example:
```python
import inquirer
questions = [
inquirer.Checkbox('interests',
message="What are you interested in?",
choices=['Computers', 'Books', 'Science', 'Nature', 'Fantasy', 'History'],
),
]
answers = inquirer.prompt(questions)
```
Checkbox questions can take extra argument `carousel=False`. If set to true, the answers will rotate (back to first when pressing down on last choice, and down to last choice when pressing up on first choice)
Another argument that can be used is `locked=`. The given choices in the locked argument cannot be removed. This is useful if you want to make clear that a specific option out of the choices must be chosen.
### Path
Like Text question, but with builtin validations for working with paths.
Example:
```python
import inquirer
questions = [
inquirer.Path('log_file',
message="Where logs should be located?",
path_type=inquirer.Path.DIRECTORY,
),
]
answers = inquirer.prompt(questions)
```
## Contributing
Contributions are very welcome.
To learn more, see the [Contributor Guide].
## License
Copyright (c) 2014-2021 Miguel Ángel García ([@magmax_en]), based on [Inquirer.js], by Simon Boudrias ([@vaxilart])
Distributed under the terms of the [MIT license][license].
[license]: https://github.com/magmax/python-inquirer/blob/main/LICENSE
[@magmax_en]: https://twitter.com/magmax_en
[@vaxilart]: https://twitter.com/vaxilart
[contributor guide]: CONTRIBUTING.md
[download the python-inquirer code from github]: https://github.com/magmax/python-inquirer
[download the wheel from pypi]: https://pypi.python.org/pypi/inquirer
[examples/]: https://github.com/magmax/python-inquirer/tree/master/examples
[inquirer.js]: https://github.com/SBoudrias/Inquirer.js
%package -n python3-inquirer
Summary: Collection of common interactive command line user interfaces, based on Inquirer.js
Provides: python-inquirer
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-inquirer
[][pypi status]
[][pypi status]
[][pypi status]
[][license]
[][black]
[][read the docs]
[][tests]
[][codecov]
[][pre-commit]
[pypi status]: https://pypi.org/project/inquirer/
[read the docs]: https://python-inquirer.readthedocs.io/
[tests]: https://github.com/magmax/python-inquirer/actions?workflow=Tests
[codecov]: https://app.codecov.io/gh/magmax/python-inquirer
[pre-commit]: https://github.com/pre-commit/pre-commit
[black]: https://github.com/psf/black
# python-inquirer
Collection of common interactive command line user interfaces, based on [Inquirer.js].
## Goal and Philosophy
Born as a [Inquirer.js] clone, it shares part of the goals and philosophy.
So, **Inquirer** should ease the process of asking end user **questions**, **parsing**, **validating** answers, managing **hierarchical prompts** and providing **error feedback**.
You can [download the python-inquirer code from GitHub] or [download the wheel from Pypi].
### Platforms support
Python-inquirer supports mainly UNIX-based platforms (eq. Mac OS, Linux, etc.). Windows has experimental support, please let us know if there are any problems!
## Installation
```sh
pip install inquirer
```
## Documentation
Documentation has been moved to [magmax.org/python-inquirer](https://magmax.org/python-inquirer/).
But here you have a couple of usage examples:
### Text
```python
import re
import inquirer
questions = [
inquirer.Text('name', message="What's your name"),
inquirer.Text('surname', message="What's your surname"),
inquirer.Text('phone', message="What's your phone number",
validate=lambda _, x: re.match('\+?\d[\d ]+\d', x),
)
]
answers = inquirer.prompt(questions)
```
### Editor
Like a Text question, but used for larger answers. It opens external text editor which is used to collect the answer.
The environment variables $VISUAL and $EDITOR, can be used to specify which editor should be used. If not present inquirer fallbacks to `vim -> emacs -> nano` in this order based on availability in the system.
External editor handling is done using great library [python-editor](https://github.com/fmoo/python-editor).
Example:
```python
import inquirer
questions = [
inquirer.Editor('long_text', message="Provide long text")
]
answers = inquirer.prompt(questions)
```
### List
Shows a list of choices, and allows the selection of one of them.
Example:
```python
import inquirer
questions = [
inquirer.List('size',
message="What size do you need?",
choices=['Jumbo', 'Large', 'Standard', 'Medium', 'Small', 'Micro'],
),
]
answers = inquirer.prompt(questions)
```
List questions can take one extra argument `carousel=False`. If set to true, the answers will rotate (back to first when pressing down on last choice, and down to last choice when pressing up on first choice)
### Checkbox
Shows a list of choices, with multiple selection.
Example:
```python
import inquirer
questions = [
inquirer.Checkbox('interests',
message="What are you interested in?",
choices=['Computers', 'Books', 'Science', 'Nature', 'Fantasy', 'History'],
),
]
answers = inquirer.prompt(questions)
```
Checkbox questions can take extra argument `carousel=False`. If set to true, the answers will rotate (back to first when pressing down on last choice, and down to last choice when pressing up on first choice)
Another argument that can be used is `locked=`. The given choices in the locked argument cannot be removed. This is useful if you want to make clear that a specific option out of the choices must be chosen.
### Path
Like Text question, but with builtin validations for working with paths.
Example:
```python
import inquirer
questions = [
inquirer.Path('log_file',
message="Where logs should be located?",
path_type=inquirer.Path.DIRECTORY,
),
]
answers = inquirer.prompt(questions)
```
## Contributing
Contributions are very welcome.
To learn more, see the [Contributor Guide].
## License
Copyright (c) 2014-2021 Miguel Ángel García ([@magmax_en]), based on [Inquirer.js], by Simon Boudrias ([@vaxilart])
Distributed under the terms of the [MIT license][license].
[license]: https://github.com/magmax/python-inquirer/blob/main/LICENSE
[@magmax_en]: https://twitter.com/magmax_en
[@vaxilart]: https://twitter.com/vaxilart
[contributor guide]: CONTRIBUTING.md
[download the python-inquirer code from github]: https://github.com/magmax/python-inquirer
[download the wheel from pypi]: https://pypi.python.org/pypi/inquirer
[examples/]: https://github.com/magmax/python-inquirer/tree/master/examples
[inquirer.js]: https://github.com/SBoudrias/Inquirer.js
%package help
Summary: Development documents and examples for inquirer
Provides: python3-inquirer-doc
%description help
[][pypi status]
[][pypi status]
[][pypi status]
[][license]
[][black]
[][read the docs]
[][tests]
[][codecov]
[][pre-commit]
[pypi status]: https://pypi.org/project/inquirer/
[read the docs]: https://python-inquirer.readthedocs.io/
[tests]: https://github.com/magmax/python-inquirer/actions?workflow=Tests
[codecov]: https://app.codecov.io/gh/magmax/python-inquirer
[pre-commit]: https://github.com/pre-commit/pre-commit
[black]: https://github.com/psf/black
# python-inquirer
Collection of common interactive command line user interfaces, based on [Inquirer.js].
## Goal and Philosophy
Born as a [Inquirer.js] clone, it shares part of the goals and philosophy.
So, **Inquirer** should ease the process of asking end user **questions**, **parsing**, **validating** answers, managing **hierarchical prompts** and providing **error feedback**.
You can [download the python-inquirer code from GitHub] or [download the wheel from Pypi].
### Platforms support
Python-inquirer supports mainly UNIX-based platforms (eq. Mac OS, Linux, etc.). Windows has experimental support, please let us know if there are any problems!
## Installation
```sh
pip install inquirer
```
## Documentation
Documentation has been moved to [magmax.org/python-inquirer](https://magmax.org/python-inquirer/).
But here you have a couple of usage examples:
### Text
```python
import re
import inquirer
questions = [
inquirer.Text('name', message="What's your name"),
inquirer.Text('surname', message="What's your surname"),
inquirer.Text('phone', message="What's your phone number",
validate=lambda _, x: re.match('\+?\d[\d ]+\d', x),
)
]
answers = inquirer.prompt(questions)
```
### Editor
Like a Text question, but used for larger answers. It opens external text editor which is used to collect the answer.
The environment variables $VISUAL and $EDITOR, can be used to specify which editor should be used. If not present inquirer fallbacks to `vim -> emacs -> nano` in this order based on availability in the system.
External editor handling is done using great library [python-editor](https://github.com/fmoo/python-editor).
Example:
```python
import inquirer
questions = [
inquirer.Editor('long_text', message="Provide long text")
]
answers = inquirer.prompt(questions)
```
### List
Shows a list of choices, and allows the selection of one of them.
Example:
```python
import inquirer
questions = [
inquirer.List('size',
message="What size do you need?",
choices=['Jumbo', 'Large', 'Standard', 'Medium', 'Small', 'Micro'],
),
]
answers = inquirer.prompt(questions)
```
List questions can take one extra argument `carousel=False`. If set to true, the answers will rotate (back to first when pressing down on last choice, and down to last choice when pressing up on first choice)
### Checkbox
Shows a list of choices, with multiple selection.
Example:
```python
import inquirer
questions = [
inquirer.Checkbox('interests',
message="What are you interested in?",
choices=['Computers', 'Books', 'Science', 'Nature', 'Fantasy', 'History'],
),
]
answers = inquirer.prompt(questions)
```
Checkbox questions can take extra argument `carousel=False`. If set to true, the answers will rotate (back to first when pressing down on last choice, and down to last choice when pressing up on first choice)
Another argument that can be used is `locked=`. The given choices in the locked argument cannot be removed. This is useful if you want to make clear that a specific option out of the choices must be chosen.
### Path
Like Text question, but with builtin validations for working with paths.
Example:
```python
import inquirer
questions = [
inquirer.Path('log_file',
message="Where logs should be located?",
path_type=inquirer.Path.DIRECTORY,
),
]
answers = inquirer.prompt(questions)
```
## Contributing
Contributions are very welcome.
To learn more, see the [Contributor Guide].
## License
Copyright (c) 2014-2021 Miguel Ángel García ([@magmax_en]), based on [Inquirer.js], by Simon Boudrias ([@vaxilart])
Distributed under the terms of the [MIT license][license].
[license]: https://github.com/magmax/python-inquirer/blob/main/LICENSE
[@magmax_en]: https://twitter.com/magmax_en
[@vaxilart]: https://twitter.com/vaxilart
[contributor guide]: CONTRIBUTING.md
[download the python-inquirer code from github]: https://github.com/magmax/python-inquirer
[download the wheel from pypi]: https://pypi.python.org/pypi/inquirer
[examples/]: https://github.com/magmax/python-inquirer/tree/master/examples
[inquirer.js]: https://github.com/SBoudrias/Inquirer.js
%prep
%autosetup -n inquirer-3.1.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-inquirer -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 3.1.3-1
- Package Spec generated